[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: iCloud directory access issue on macOS Catalina

From: Pankaj Jangid
Subject: Re: iCloud directory access issue on macOS Catalina
Date: Sat, 12 Oct 2019 12:43:06 +0530
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.3 (darwin)

Perry Smith <> writes:

> Someone at the EmacsForMacOS GitHub discovered a few things about
> this.  (Not exactly solved but a relatively simple work around)
> Add to "Full Disk Access", then inside Emacs, use
> ns-open-file-using-panel (bound to Cmd-o by default) to open an
> arbitrary **file** directly inside ~/Documents.  The GUI won't let you
> open a directory.  I bet that could be enhanced a little.  After that
> emacs can dired in ~/Documents.

I confirm that this approach worked on my Mac.

> There seems to be three of these: ~/Documents, ~/Desktop, and
> ~/Downloads. I'm surprised ~/Downloads is in there because its not
> copied to iCloud.

Yes. ~/Downloads is surprising. This implies that the problem isn't
related to iCloud but it is some other permissions stuff, which is
specific to macOS 10.15 (Catalina).

> The ns-open-file-using-panel must be done once for each of these
> three. After that, it appears to work forever and ever. I even
> rebooted and it still worked.

Pankaj Jangid

reply via email to

[Prev in Thread] Current Thread [Next in Thread]