[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: iCloud directory access issue on macOS Catalina

From: Pankaj Jangid
Subject: Re: iCloud directory access issue on macOS Catalina
Date: Thu, 31 Oct 2019 19:09:07 +0530
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.3 (darwin)

Pankaj Jangid <> writes:

> macOS is increasingly making it difficult to access directories. Even
> its own terminal required permission for CDing into icloud directories.
> I am facing the same in dired. Just wanted to know if anyone has got this
> fixed. I tried to gave "Full Disk Access" to Emacs but still getting
> this error.
> ```
> Debugger entered--Lisp error: (error "Listing directory failed but 
> ‘access-file’ worked")
>   signal(error ("Listing directory failed but ‘access-file’ worked"))
>   error("Listing directory failed but `access-file' worked")
>   insert-directory("/Users/pankaj/Documents/" "-al" nil t)
>   dired-insert-directory("/Users/pankaj/Documents/" "-al" nil nil t)
>   dired-readin-insert()
>   dired-readin()
>   dired-internal-noselect("~/Documents/" nil)
>   dired-noselect("/Users/pankaj/Documents/" nil)
>   dired-other-window("/Users/pankaj/Documents/" nil)
>   funcall-interactively(dired-other-window "/Users/pankaj/Documents/" nil)
>   call-interactively(dired-other-window nil nil)
>   command-execute(dired-other-window)
> ```

This issue has re-appeared in macOS 10.15.1 update. And the workaround
using ns-open-file-using-panel is also not working this time.

Pankaj Jangid

reply via email to

[Prev in Thread] Current Thread [Next in Thread]