[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Tramp prompt (?) issue

From: Emanuel Berg
Subject: Tramp prompt (?) issue
Date: Wed, 29 Jul 2020 02:22:54 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.1 (gnu/linux)

Tramp doesn't seem to work at all for me [1].

I tried to get to two different systems [2], one with
a password, one with RSA.

Both are accessible for me thru the ssh shell command
no problem.

I tried with the modified tramp-shell-prompt-pattern
below (I got it from someone else) as well as the
default value.

I tried with -q and -Q.

All same. What happens is

  Waiting for prompts from remote shell...

then nothing, so I do C-g.

(require 'tramp)
(setq tramp-verbose 10)

(setq tramp-shell-prompt-pattern
      "^[^$>\n]*[#$%>] *\\(\[[0-9;]*[a-zA-Z] *\\)*")

(setq tramp-default-method "ssh")

(find-file "/")
(find-file "/")

[1] GNU Emacs 26.1 (build 2, x86_64-pc-linux-gnu) of
    2019-09-23, modified by Debian

[2] SunOS 5.10 Generic_150401-59
    i86pc i386 i86pc Solaris

    OpenBSD 6.7 GENERIC#2 amd64

underground experts united

reply via email to

[Prev in Thread] Current Thread [Next in Thread]