[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Windows10 with MSYS2 shell: Can't erase directories from Emacs' git

From: H. Dieter Wilhelm
Subject: Re: Windows10 with MSYS2 shell: Can't erase directories from Emacs' git repo tree
Date: Thu, 11 Nov 2021 23:19:39 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/28.0.60 (windows-nt)

Eli Zaretskii <> writes:

>> From: "H. Dieter Wilhelm" <>
>> Date: Tue, 09 Nov 2021 22:27:42 +0100
>> I created a git clone of the sources, added some worktrees, changed the
>> contents of one file.  And decided to start anew but now I can't delete
>> all folders of the repo, Windows says I would need admin rights to
>> remove the remaining folders!  (The files in the tree are gone but not
>> all folders.)  When I'm looking at the properties of the remaining
>> folders it says they are all write protected and nobody is allowed to
>> remove the folders!  It seems the only thing I can do it to rename these
>> folders.
>> Is this a known problem with Windows10?
> No.  But you didn't describe what you tried to do in enough detail to
> understand what could be the problem in your case.  Please add a more
> detailed description, including which folders cause the problem.

   - master
      - admin
         - nt
            - dist-build

I had a complete Emacs branch under master/, created by git worktree,
changed one file under dist-build/ (without comitting).  Then I wanted
to get rid of the complete repository and tried to erase the git/
folder.  I can't remember if I tried it first in dired (likely) or in
the MSYS2 shell.

All files and some folders are removed, only the folders which were
leading to the changed file are intact but I can't remove any of these
remaining folders!

> Also, what is your Windows user? is it, per chance, Administrator?

I don't know how to tell with Windows and this is a company machine.
I'm able to install programs but I'm not an IT admin.  I heard that our
IT guys were talking about "Open User" rights but I don't know if that
is a proper term or what that means.

> What does Emacs say about the owner and the group of those problematic
> folders?

I can only tell what dired shows, is there another way in Emacs?.  Dired
shows that I'm owner and that the folders belong to the group I'm member
of.  That is the same as the MSYS shell says.

When I'm looking at the folder properties, Windows tells me that they
are Read-only.  I can change this property but after reopening the
attributes they are again? read-only.  The only thing I can do is to
rename the folders...

Thank you for interest


reply via email to

[Prev in Thread] Current Thread [Next in Thread]