[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Windows10 with MSYS2 shell: Can't erase directories from Emacs' git

From: H. Dieter Wilhelm
Subject: Re: Windows10 with MSYS2 shell: Can't erase directories from Emacs' git repo tree
Date: Fri, 12 Nov 2021 07:55:47 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/28.0.60 (gnu/linux)

Óscar Fuentes <> writes:

> "H. Dieter Wilhelm" <> writes:
>>   git
>>    - master
>>       - admin
>>          - nt
>>             - dist-build
>> I had a complete Emacs branch under master/, created by git worktree,
>> changed one file under dist-build/ (without comitting).  Then I wanted
>> to get rid of the complete repository and tried to erase the git/
>> folder.  I can't remember if I tried it first in dired (likely) or in
>> the MSYS2 shell.
>> All files and some folders are removed, only the folders which were
>> leading to the changed file are intact but I can't remove any of these
>> remaining folders!
> Did you reboot the machine since? Either reboot the machine or check
> that you don't have any leftover running processes from the build.
> Windows won't delete a file that is opened by a process, or a directory
> that is the working directory of a process.

Yes, I rebooted the machine already and still can't erase the folders.

> Exit any MSYS2, CMD or Emacs shell, launch the Task Manager and in the
> Details pane look for instances of `make', `gcc', `sh', `bash', `cmd',
> `git', etc. Kill those processes and try removing the problematic
> file/folder from Windows Explorer.

But I'll double check this and report the outcome

Thank you for the hints


Best wishes
H. Dieter Wilhelm
Zwingenberg, Germany

reply via email to

[Prev in Thread] Current Thread [Next in Thread]