[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Trouble Running GNUStep on Windows XP

From: michael
Subject: Trouble Running GNUStep on Windows XP
Date: Sat, 1 Sep 2007 14:27:59 -0700 (PDT)

Hi everyone. I am new to GNUStep, but have some basic
experience with Xcode on OS X. I decided to see if I
could get one of my Cocoa programs to run on Windows,
so I tired to install GNUStep. Instead of building the
source, I installed the GNUStep core from
Then I downloaded the latest versions of ProjectCenter
and Gorm. I built ProjectCenter with the make install
command and tried to run it by double clicking the
.exe in the folder. It complained of
some .dlls not being found, so I added the following
directories to my path: 
After that I ran it and it seemed to run fine, but it
asked me for a window server and I selected WinDows
server or something like that. After that I was left
with a button with a target and some arrows on it but
pressing it would not do anything. Now when I run the
program I get no button and these errors:
[2244] Exception occured while loading model: attempt
to set non property list for key (BundlePaths)
[2244] Failed to load Gorm
[2244] Could not load Gorm file ...\ProjectCenter.gorm
[2244] Cannot load the main model file

Thinking that installing Gorm would fix the problem, I
built it using make install as well. It didn't get
copied to the System/Applications folder of the
install path, so I moved it there manually. It actuall
works better than ProjectCenter, but has some problems
of its own. I did the window server setup like before
with this one but left it on the default NeXTStep
style theme. Its problem starts when choosing new
application. I get a blank window for the application,
but I can't drag anything from the Palette since it
says something like "No Current Document" even though
there is a new window open to work with. And the
console has these errors:
[3392] Exception occured while loading model: expected
object and got unsigned char.
[3392] Failed to load gorm
[3392] NSWindowController: could not load nib named

Trying to open either one with openapp in MinGW
produces an error like this one:
Could not find

I was wondering if there is anything I can do to fix
my installation or if I need to track down a stable
build. Not really sure where to go from here... 

Thanks In Advance,

Luggage? GPS? Comic books? 
Check out fitting gifts for grads at Yahoo! Search

reply via email to

[Prev in Thread] Current Thread [Next in Thread]