[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Installed GNUstep on Ubuntu 16.04 – Or Have I?

From: Ivan Vučica
Subject: Re: Installed GNUstep on Ubuntu 16.04 – Or Have I?
Date: Sun, 31 Mar 2019 20:30:46 +0000

Hey hey,

answers inline. I’m one of the rare people answering to help-gnustep@ mails; you may have further responses if you include discuss-gnustep@ in this thread.

On 31 Mar 2019, at 18:05, Ignatzzzz <> wrote:

Hi All,

Complete novice at this, not a UNIX expert, I just wanted to see if I could
install GNUstep on Ubuntu 16.04 on a Rasperry Pi, to enable me to relive my
old NeXTSTEP days.

In Terminal, I did:

sudo apt-get install gnustep


sudo apt-get install gnustep-devel

Everything proceeded without any errors.

Then I ran the installer script from here:

Again, everything proceeded without error. I now see that I have several new
GNU Applications in the Applications browser, but when I start them, they
all have a NextSTEP-like appearance, apart from the title bars, which are
sill Ubuntu. How do I get just GNUstep running without GNOME desktop?

It’s a common misconception that I shared years ago — but GNUstep is not really a full environment. It really is a set of libraries that let you write Objective-C apps — not an environment as such. Think GTK and glib, not GNOME; or think Qt, not KDE.

Individual users (some core devs among them) often set up something that looks like “a GNUstep environment” — but the project really ships nothing of the sort at this time.

Efforts are often underway outside the core project to provide such an environment; for instance, currently NEXTSPACE ( is under development. I don’t think it ships in any of the distributions at this time.

Easiest way to get something that could be seen as a GNUstep environment is to pick the WindowMaker session in your login manager, then start things like the,, etc.

assume I'll need some sort of Terminal start-up script to launch and kill GNOME? I just have no idea how to go about it. I
tried 'sudo service gdm stop' while GWorkspace was running, but just got
'Failed to stop gdm.service: Unit gdm.service not loaded'. Any help would be
gratefully appreciated.

(Note: Given you mentioned you are running Ubuntu 16.04, I think I’m safe in assuming you are running an X11-based environment, and not Wayland based environment.)

GDM is your login manager. These days, login managers run the X11 server for you, and let you sign in.

When people recommend you stop GDM, they effectively tell you to stop the X11 server and end any running sessions more than anything else. (They may actually want you to reload GDM configuration, but I’d expect that the advice you read was trying to make you do this.)

Now, the error you’re getting means that your OS is not actually running GDM as the login manager or that it even has it installed. Given it’s Ubuntu, I’d expect that it’s running lightdm instead. Now, do keep in mind, if you stop lightdm, just like with GDM and other login managers, you /will/ end up terminating your graphical session — this doesn’t mean you’ll be able to see GNUstep without GNOME, but that you will be signed out *and* dropped to a fully text based environment. (This is the only thing that can happen, given that you will terminate the X server. It’s easy to start it back up, as long as there’s no bugs and you can actually see the text display. But, be warned.)

What you instead want to do is install WindowMaker, and, when asked for username and password by lightdm, choose WindowMaker.

WindowMaker is not part of GNUstep, but it has the appropriate look&feel.

Alternatively, you may want to run under GNOME or Unity, but use GNUstep’s SystemPreferences to switch from NeXT-like theme to the GTK theme. (Assuming it’s installed.)

To avoid confusion with numerous other “system” configuration utilities that may be installed on your system, instead of using the launcher menu, you can literally type this into terminal to launch GNUstep's globally-installed SystemPreferences, if it’s installed — do note that UNIX is case sensitive. You’ll get the right one because nearly nobody else but GNUstep uses upper-case characters in app binary names. :-)

Good luck!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]