[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: new GuixSD version?

From: Ethan Stefan Day
Subject: Re: new GuixSD version?
Date: Thu, 21 Jul 2016 15:23:44 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Icedove/45.1.0

On 07/20/2016 01:59 AM, Leo Famulari wrote:
> On Wed, Jul 20, 2016 at 12:45:49AM -0400, Ethan Stefan Day wrote:
>> If my concern is based on accurate understanding, I would be willing to
>> test it.  I was about to reinstall GuixSD on metal for unrelated reasons.
> Yes, please report anything that's missing.

So I guess the installer was more resilient than I expected;  it worked
fine.  (using default desktop configuration on x86_64)  It took a long
time, but from what Ludovic was saying, that was expected.  Optional
details follow:

My initial plan was to run 'guix system init', look at what failed, and
try to resolve missing dependencies.  So I ran:

time guix system init --fallback --keep-going /mnt/etc/config.scm \
/mnt &>> /mnt/unique-logging-dir-9855/run-one.log

It took about 6 hours (on my fairly powerful modern laptop).
run-one.log is 96.4 MB, so going through it by hand was not an option.
Luckily, the last line was:

Installation Finished.  No error reported.

I have not done anything yet, but it boots and lets me log in as root.
If the log file is of interest, I am willing to share it if someone
provides a way to transfer it or gives me a hint about how to extract
the relevant information programmatically.

There was some other output from the system that resulted from that
command.  I have no idea what it means.  Also, it was copied by hand, so
there may be errors.  here it is:

spurious SIGPOLL
spurious SIGPOLL
spurious SIGPOLL
spurious SIGPOLL
spurious SIGPOLL
[ 6791.830086] traps: test-libnm-link[4412] trap int3 \
    ip:7fffffff9fe0 error:0
[ 6791.831123] NOHZ: local_sofirq_pending 282
[ 6791.832111] NOHZ: local_sofirq_pending 282
[ 6791.832991] NOHZ: local_sofirq_pending 282
[ 6791.833747] NOHZ: local_sofirq_pending 282
[ 6791.830059] perf interrupt took too long (2503 > 2500), \
   lowering kernel.perf_event_max_sample_rate to 50000

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]