[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: no patch applies

From: Catonano
Subject: Re: no patch applies
Date: Fri, 5 Aug 2016 15:07:19 +0200

2016-08-05 12:09 GMT+02:00 Ricardo Wurmus <address@hidden>:

Vincent Legoll <address@hidden> writes:

> Hello
>>> I attempted to apply the patch onto a fresh Guix master and the patch does
>>> not apply, I don't know why
> When I fail to apply a patch that's often because of a wrong -p parameter.
> Try with "--dry-run -p0" or "--dry-run -p1" to find the good one. You can also
> look at file paths in the patch and deduce the right path strip level.

I haven’t used “patch” in quite a while because usually “git am
the-patch-file” just works.  If the patch was created with “git
format-patch” against master you shouldn’t have any problems using “git
am” on it.

~~ Ricardo

Thank you all people for your help. I appreciate that.

Yes, Ricardo, you nailed it

I had attempted with

  git apply --check path/to/the.patch

because I read that it is a good idea to verify the applicability of a patch before actually applying it

Then I tried with a simple

  git am path/to/the.patch

and it worked like a breeze

I looked at the log and there's the commit of the patch on top of f467c35261

I had wrongly assumed that "git apply --check.." and "git am..." would have envisioned the same process
So what's the use case for "git apply --check.." ? Bah...

Thanks again

reply via email to

[Prev in Thread] Current Thread [Next in Thread]