[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: wrapping freexl in guile

From: Jelle Licht
Subject: Re: wrapping freexl in guile
Date: Sat, 03 Jun 2017 22:46:20 +0200
User-agent: mu4e 0.9.18; emacs 25.2.1

Catonano <address@hidden> writes:

> I copied guile-gcrypt
> I changed all the occurrrences of "gcrypt" in "freexl" in all the relevant
> files
> I created an env with
> ~/projects/guile-freexl$ guix environment -l ./guix.scm --ad-hoc guile
> freexl
> I run configure and I got
> checking for libfreexl-config... no
> checking libfreexl's library directory...
> checking for libfreexl shared library name... libfreexl
> checking whether libfreexl can be dynamically loaded... no
> configure: error: GNU libfreexl does not appear to be usable; see
> `--with-libfreexl-prefix' and `README'.

I quickly tried:
`./configure --with-freexl-prefix=$GUIX_ENVIRONMENT'
and that seems to complete (a `make' invocation afterwards
understandably fails).

Maybe the following link might help you? It was actually about gcrypt ;-).

> If I do the same in guile-gcrypt it builds successfully
> Why ?
> P.S. it's here
> P.P.S I tried with both "libfreexl" AND "freexl"

Thanks for working on this!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]