[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Issues with my configuration - zsh shell default

From: Ricardo Wurmus
Subject: Re: Issues with my configuration - zsh shell default
Date: Wed, 05 Jul 2017 10:30:42 +0200
User-agent: mu4e 0.9.18; emacs 25.2.1

> This worked for me. Thanks. What is the best way of looking up what package
> belongs to what module? In case I hit more of this in the future.

You can use “guix package -s zsh” and then use recutils to match on the
“name” field and print the “location” field.  The location matches the
module name:

   gnu/packages/shells.scm –> (gnu packages shells)
> You can only tell Guix not to try to mount the disk on boot.  Use
> Tried doing something similar but getting errors on the read-string.
> First I got:
> guix system: error: failed to load '/etc/config.scm':
> /etc/config.scm:23:24: /etc/config.scm:23:24: In procedure module-lookup:
> Unbound variable: read-string
> After searching in the guile manual I found a read-string in the module
> (sxml ssax input-parse), loaded that and now I get.

That’s not the right “read-string”.  You need to load (ice-9 rdelim).
The sxml stuff is for parsing XML.


GPG: BCA6 89B6 3655 3801 C3C6  2150 197A 5888 235F ACAC

reply via email to

[Prev in Thread] Current Thread [Next in Thread]