[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: libvirt

From: Catonano
Subject: Re: libvirt
Date: Mon, 18 Dec 2017 23:13:51 +0100

2017-12-18 19:48 GMT+01:00 Christopher Baines <address@hidden>:

Catonano <address@hidden> writes:

> 2017-12-12 17:46 GMT+01:00 Catonano <address@hidden>:
>> 2017-12-12 15:56 GMT+01:00 Ricardo Wurmus <address@hidden>:
>>> Hi Catonano,
>>> > I need a libvirt daemon running in order to use virt-manager
>>> You just need to have the libvirt service with the default
>>> configuration, and then you should be able to use virt-manager.  Have
>>> you tried that?
>> No, I hadn't tried.
>> I saw 2 services, didn't understand and got scared
>> Thanks :-)
> Ok, I reconfigured
> virt-manager still can't start:
> libvirtError: Failed to connect socket to '/var/run/libvirt/
> libvirt-sock': Permesso negato (denied permission)
> ~$ ls -lhad /var/run/libvirt
> drwxr-xr-x 8 root root 4,0K 12 dic 18.43 /var/run/libvirt/
> ~$ sudo herd status libvirt
> Password:
> herd: service 'libvirt' could not be found
> am I doing anything wrong ?

Just in case you or someone else wants to use libvirt. I think the
service is called libvirtd, and you probably need to make sure you're
user is in the libvirt group.

Thank you Chris !

I managed to launch the GUI client (virt-manager ?) but I found it too dificult, with too many options to figure out

Maybe had I made sure that my user was in the libvirt group, the experience would have been different

But I moved to my Fedora desktop and used Boxes. Way simpler

It'd be nice to have Boxes on GuixSD too
Maybe some day I'll send a patch ;-)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]