[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Installing GuixSD on an external USB hard drive

From: Divan Santana
Subject: Re: Installing GuixSD on an external USB hard drive
Date: Tue, 17 Apr 2018 15:04:49 +0200

Divan Santana <address@hidden> writes:

> Hi Guix,
> So I'm installing GuixSD on an external USB hard drive.
> This is obviously quite useful to test and setup all before you switch
> to it. I plan to eventually install on laptop.
> I could do it in a VM but...
> Anyway, the install went flawless and docs are great.
> *After a reboot*, I did a guix pull and system reconfigure.
> (I did change the drive letter, since post reboot grub was on sdb, not c)
> I got an error saying:
> unknown location, you may need these modules in the initrd: uas
> usb_storage .
> It then pastes the snippet of code. Really cool and useful.
> Though, bit confused why the install worked and rebooted, yet post
> reboot I now require it?
> Moving on, I add the snippet of code but it errors out with:
> usb_storage module not found.
> A find shows the module is in the 4.16 dir, named usb-storage.
> Note - not _.
> I thought perhaps that's the issue so I changed the code to specify mod
> usb-storage (not _).
> However I then get the orig error, that I should add usb_storage mod in
> initrd-modules.
> Suppose the question is why is usb_storage not found?
> Any ideas?
> (sorry for lack of exact messages, don't have remote access to system at mo)

OK, I think this is a bug.

The way I worked around it was to:

1) remount /gnu/store rw


cp usb_storage.ko usb-storage.ko

As said earlier guix doesn't allow me to specify usb-storage in the scm
file and it suggests usb_storage, which it fails to find without the
above hack. Prob gets it from lsmod which reports usb_storage while the
file is usb-storage.ko

This is obviously not right.

Prob a simple fix but out of my capabilities at the mo.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]