[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Guix on Android works, guix pull fails on guile-ssh build in the che

From: 白い熊@相撲道
Subject: Re: Guix on Android works, guix pull fails on guile-ssh build in the check phase
Date: Sun, 13 May 2018 16:02:33 +0000

On May 13, 2018 2:49:02 AM UTC, Chris Marusich <address@hidden> wrote:

>If those failures occur on the latest version of guile-ssh, it might be
>helpful to open a bug report upstream:

I filed it—thanks for notifying me of this, prior to that I only reported it to 
Artyom via email, as instructed by the failed build of guile-ssh. He hasn't 

>How did you invoke "guix pull"?  Based on your suggested plan of
>it sounds like you modified the Guix source locally (on your Android
>system), recompiled it, and then tried to use "guix pull" from that
>newly built version.  Something like that.  Is that right?

I didn't modify it in any way—it's run from the 0.14.0 armhf binary download. 

What I wrote about—modifying it—I'm simply thinking about. I would still hope 
the failure is fixed upstream as it shouldn't be failing on guix rebuild. 

The “hoops to jump through” I was referring to are the setup on Android 
side—you need to symlink /gnu and /var every reboot, create /etc/resolv.conf 
etc. But no modifications to Guix per se are necessary… 

>If you don't tell "guix pull" where to get the Guix source from, it
>the latest version from the Git repository hosted on Savannah.  If it
>does that, then it will use the package definitions from that version,
>which means it won't use any of the local changes you made.  I think
>what you need to do, if you want to disable the guile-ssh tests, is
>something more like this:
>  guix pull --url=file:///path/to/your/custom/guix/repo
>You might also need to use the --commit or --branch options, as
>described in the manual (see: "(guix) Invoking guix pull").  You might
>not need to specify the "file://" prefix in the URL; I can't remember.
>If you invoke "guix pull" in this way, you are telling it to use the
>version specified by what you have *committed* in your custom Guix
>Make sure you commit the change that disables guile-ssh tests, or it
>won't be included when "guix pull" fetches from the repo.
>If you do "guix pull" in this way, it should build the custom version
>guile-ssh that you made which disables the tests.  I haven't tried this
>myself, though, so no guarantees!  I hope it helps.

Thanks for this guide—I'll try to experiment with it, if guile-ssh doesn't get 
fixed soon… 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]