[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

National alphabet not works in bash

From: znavko
Subject: National alphabet not works in bash
Date: Fri, 4 Jan 2019 11:32:13 +0100 (CET)

Hello! After reconfigure without any changes or maybe after update bash does not work with Russian characters.

I am typing in Russian:

# ?????????????????
-bash: ?????????????????: command not found
# ??????
-bash: ??????: command not found

$ locale -a
bash: locale: command not found

Terminal: xfce4-terminal
Preferences: Encoding: Default ANSI_X3.4-1968
I did not changed anything.

Tried to solve the problem with Guix Manual, section '6.2.6 Locales', but I discovered I have Russian locales already:

# ls /run/current-system/locale/2.28/
ca_ES.utf8/  en_CA.utf8/   es_ES.utf8/  fr_FR.utf8/  nl_NL.utf8/  tr_TR.utf8/
cs_CZ.utf8/  en_GB.utf8/   es_MX.utf8/  ga_IE.utf8/  pl_PL.utf8/  uk_UA.utf8/
da_DK.utf8/  en_US.utf8/   fi_FI.utf8/  it_IT.utf8/  pt_PT.utf8/  vi_VN.utf8/
de_DE.utf8/  en_US.UTF-8/  fr_BE.utf8/  ja_JP.utf8/  ro_RO.utf8/  zh_CN.utf8/
el_GR.utf8/  es_AR.utf8/   fr_CA.utf8/  ko_KR.utf8/  ru_RU.utf8/
en_AU.utf8/  es_CL.utf8/   fr_CH.utf8/  nb_NO.utf8/  sv_SE.utf8/

Nevertheless I tried to add the line 'locale-definition' to config.scm, but got the error:

# head -n 25 /etc/config.scm
;;this is znavko's cute config

(use-modules (gnu) (gnu system nss)
             (gnu system locale) ;;for locale-definition
             (gnu services desktop)
             (gnu services dns) ;;for dnsmasq
             (srfi srfi-1) ;;for remove function
             (gnu services networking) ;;for remove ntp
             (gnu services avahi) ;;for remove avahi
             (gnu services xorg)
             ;;(gnu services databases);;for postgres
             (gnu packages admin) ;;for wpa_supplicant

(use-service-modules desktop)
(use-package-modules certs gnome)

(operating-system (host-name "antelope") (timezone "Europe/Moscow") (locale "en_US.utf8")
  (cons (locale-definition
        (name "ru_RU.utf8") (source "ru_RU"))
  (bootloader (bootloader-configuration
                (bootloader grub-bootloader)
                (target "/dev/sda")))
  (file-systems (cons (file-system

# guix system reconfigure /etc/config.scm
/etc/config.scm:18:2: error: invalid field specifier

How to retrieve Russian characters in terminal?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]