[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GuixSD on a laptop with Heads

From: Tobias Geerinckx-Rice
Subject: Re: GuixSD on a laptop with Heads
Date: Wed, 01 May 2019 13:19:12 +0200


I haven't flashed Heads myself, but am passingly familiar with it since I do basically the same thing on my hardware including an X230 (and intend to recreate that on top of Guix, eventually).

Jonathan Frederickson wrote:
However, I'm running into some issues when attempting to boot into the new kernel - the moment I run kexec, I get no output onscreen from the new kernel:

I've tried adding the usual debug flags to the kernel command line for troubleshooting (debug, higher LOGLEVEL, earlyprintk to vga) with no change.

That won't help if there's nowhere to print to. From your screenshot, you're not in VGA mode, for example. Is that screenshot from within Heads? Which graphics driver is Heads using at that point? Have you tried adding the same driver to the initrd?

 (initrd-modules (cons* "i915" %base-initrd-modules)))

It's also possible that Heads uses the Coreboot ‘simple’ framebuffer, for which you'll have to set at least the following kernel options:


[Google isn't even being coy about stealing credit for others' work anymore.]

Unfortunately, that requires compiling a custom kernel.

Just some ideas,


Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]