[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

IceCat from Guix all monospaced font

From: Zelphir Kaltstahl
Subject: IceCat from Guix all monospaced font
Date: Sat, 4 May 2019 19:19:40 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.6.1

Hello Guix Users,

Today I installed GNU Icecat from Guix and everything works fine, except
for one thing:

The whole Icecat UI uses a monospaced font and on every website
everything is monospaced. I've tried for hours to change fonts using
userChrome.css to no avail. I also tried inspecting the UI using the
browser toolbox and it shows, that my userChrome.css set values are used
for the UI. Although in that inspector I see font family values like
"Liberation Sans" and "DejaVu Sans" and "sans-serif", the UI _actually_
still is monospaced.

While I generally like "monospaced-ness", the problem is, that it breaks
Icecat's UI in many places, as the UI is not flexible enough to render
all texts and often cuts text overflow, as the monospaced font is wider
than what one would usually have.

My guess is, that somehow Icecat installed via Guix is not able to pick
up system wide installed fonts and always, no matter what I set, falls
back to a monospaced font. Following this guess, I installed Liberation
fonts and DejaVu fonts in Guix. However, still everything is monospaced.

Also note, that I created a completely new user profile for Icecat, in a
non-default path in `~/user/.icecat/profiles`. So everything there
should be clean. That directory did not even exist, when I created the

Here is the content of my userChrome.css:


@namespace url(;
/* -moz-use-system-font */
/* Global UI font */
* {
  font-size: 11pt !important;
  font-family: Liberation Sans, DejaVu Sans, Ubuntu, sans-serif;

:root {
  --tab_min_width: 24px;
  --tab_max_width: 100px;
  --toolbarbutton-outer-padding: 1px !important;
  --toolbarbutton-inner-padding: 2px !important;
  --tab-min-height: 24px !important;
  --space-above-tabbar: 0px !important;

@-moz-document domain(){
  font-family: sans-serif !important;

/* change font of tabs */
.tabbrowser-tab {
  font-family: Ubuntu, sans-serif;

/* decrease max height of the tab bar */
#tabbrowser-tabs {
  max-height: 25px;

#tabbrowser-tabs * {
  max-height: 25px;

#tabbrowser-tabs .tabbrowser-arrowscrollbox {
  max-height: 25px !important;
  padding-top: 1px !important;
  padding-bottom: 1px !important;
  margin-top: 0px !important;
  margin-bottom: 0px !important;
  text-shadow: none !important;

/* decrease height of the tabs */
/* normal tabs */
.tabbrowser-tab:not([pinned]) {
  height: 24px !important;

.tabbrowser-tab:not([pinned]) .tab-icon-image {
  margin-top: 0px;
  margin-bottom: 0px;
  padding: 0px;
  height: 16px;

/* pinned tabs */
.tabbrowser-tab[pinned] {
  width: 24px !important;
  height: 24px !important;
  border: none;

.tabbrowser-tab[pinned] .tab-icon-image {
  margin: 2px;
  padding: 0px;
  height: 16px;
  width: 16px;

.tab-content {
  max-height: 24px !important;
  padding-top: 0px !important;
  padding-right: 2px !important;
  padding-bottom: 0px !important;
  padding-left: 2px !important;

#navigator-toolbox #TabsToolbar {
  padding-right: 0px !important;
  padding-left: 0px !important;
  min-height: unset !important;
  /* background-color: #ffffff !important; */
  height: unset !important;
  min-height: unset !important;


Does anyone know how to fix this monospaced issue? Please help me make
my Icecat more usable : ) Thank you!



reply via email to

[Prev in Thread] Current Thread [Next in Thread]