[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: docker-compose not work

From: Edison Ibáñez
Subject: Re: docker-compose not work
Date: Sun, 16 Jun 2019 19:42:16 -0500
User-agent: mu4e 1.2.0; emacs 26.2

Hello Tobias

I have tried to update the package as you can see in the paste

but I still have the same error.

for work reasons I have to use docker for the different projects in which he 

El domingo 16 de junio del 2019 a las 1246 horas, Tobias Geerinckx-Rice 

> Arkhan,
> address@hidden wrote:
>> regards,
> Hullo, and welcome to Guix!
>> install docker and docker-compose but at the time of executing it I
>> have the following error
> […]
>> pkg_resources.DistributionNotFound: The 'jsonschema<3,>=2.5.1'
>> distribution was not found and is required by docker-compose
>> apparently the dependencies of this package are wrong,
>> someone can tell me how I can solve it.
> The root of this problem is that our docker-compose package is *very*
> old: it was added in January 2016(!), and has never been updated
> since.  I guess that proves how unneccessary Docker is once you've
> discovered Guix…  *ducks*
> We have docker-compose 1.5.2.  Upstream is currently at
> 1.24.0. Updating it probably won't be trivial (although I haven't
> checked in detail—it might be).
> However, even 1.24.0 complains about jsonschema<3,>=2.5.1 not being
> found.  Since Docker insists on using an old library, and I don't feel
> comfortable removing the version constraints (I don't use Docker),
> I've added it back on master and told docker-compose to use it.
> Could you guix pull and try an updated docker-compose?  If you're very
> lucky, this more than 3-year-old piece of software will just work.  If
> not, please open a bug by sending your message to address@hidden.
> Thanks!
> T G-R

reply via email to

[Prev in Thread] Current Thread [Next in Thread]