[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: guix system init with mounted btrfs

From: Matt Huszagh
Subject: Re: guix system init with mounted btrfs
Date: Sun, 23 Jun 2019 14:10:48 -0700
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.1 (gnu/linux)

Tobias Geerinckx-Rice <address@hidden> writes:

Matt Huszagh <address@hidden> writes:
> Ok, so I've simplified the subvolume layout somewhat:
> mount -t btrfs -o compress=lzo LABEL=btrfs /mnt
> btrfs subvolume create /mnt/@guixsd
> btrfs subvolume create /mnt/@home
> btrfs subvolume create /mnt/@snapshots
> umount /mnt
> o_btrfs=defaults,X-mount.mkdir,compress=lzo,ssd,noatime
> mount -o subvol=@guixsd,$o_btrfs LABEL=btrfs /mnt
> mount -o subvol=@home,$o_btrfs LABEL=btrfs /mnt/home
> mount -o subvol=@snapshots,$o_btrfs LABEL=btrfs /mnt/.snapshots
> mount -o X-mount.mkdir /dev/nvme0n1p1 /mnt/boot/efi

I think I was a bit hasty in saying this worked. Another possible reason
is guix system init doesn't try to do anything with these directories
anyway so maybe the fact that these subvolumes are "supported" is a
false positive.

I've tried an even simpler layout: no subvolumes, just

mount -t btrfs -o defaults,compress=lzo,ssd,noatime LABEL=btrfs /mnt
mount -o X-mount.mkdir /dev/nvme0n1p1 /mnt/boot/efi

However, I'm experiencing the same decryption error with this setup.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]