[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: guix system init with mounted btrfs

From: Matt Huszagh
Subject: Re: guix system init with mounted btrfs
Date: Mon, 24 Jun 2019 07:51:00 -0700
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.1 (gnu/linux)

Efraim Flashner <address@hidden> writes:
> I spent some time yesterday with the arch wiki and I have an idea.
> assuming you're using %desktop-services, inside services:
> (modify-services %desktop-services
>   (udev-service-type config =>
>                      (udev-configuration
>                      (inherit config)
>                      (rules (list lvm2 fuse alsa-utils crda btrfs)))))
> Perhaps adding the udev rules for btrfs will force it to run 'btrfs
> device scan' or whatever the magic is that it apparently isn't running
> now.

Thanks for the suggestion Efraim. I don't currently use desktop
services, just base-services at the moment. However, I'm concerned there
may still be an issue with this modification. I'm currently only getting
prompted for 1 of 2 LUKS device passphrases, which I believe is an issue
with the grub bootloader (which in my case is an efi shell program). I'm
getting stuck at the grub rescue prompt and so I don't even get to the
initial ramdisk stage. Is that where these services kick in, or does
that happen later when the full kernel is loaded? When I mount the btrfs
root fs manually, I have to decrypt both devices before I can run btrfs
device scan.

To address the grub issue I've tried doing:
grub rescue> insmod luks
grub rescue> cryptomount -a

However, that doesn't appear to have any effect. I've also tried
modifying grub.cfg directly and reinstalling the bootloader by chrooting
and running grub-install, but that doesn't work for reasons that seem to
be related to the guix way of doing things. Since I'm still new to Guix,
I don't know how one might make custom modifications to the cfg file.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]