[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: grub with encrpted root no longer automatically loads luks

From: Jack Hill
Subject: Re: grub with encrpted root no longer automatically loads luks
Date: Tue, 25 Jun 2019 23:50:00 -0400 (EDT)
User-agent: Alpine 2.20 (DEB 67 2015-01-07)

Thanks for you reply.

On Fri, 21 Jun 2019, Giovanni Biscuolo wrote:

Hello Jack,

I don't have a Guix machine using root on encrypted LUKS now, but I
tested this non so long ago and it worked well

Jack Hill <address@hidden> writes:

I've noticed that recently (unfortunately, I don't know exactly when it
started), that grub no longer prompts me to enter my password to unlock my
root filesystem.

Are you able to boot to a previous Guix System generation and try to
find the one that introduced this behaviour?

No, I can't boot into a previous generation, as the problem seems to be with grub reading from the store. I have not yet tried reconfiguring with an older version of Guix.

Are you sure you did not reconfigured your device mapping meanwhile?

I am reasonable certain that I have not done this.

I notice that at the grub command line, if I enter
`cryptomount -a`, I am not prompted for a password, and the root
filesystem does not become available. However, if I first run `insmod
luks` and then `cryptomount -a`, I am prompted for my password, and the
root filesystem become available and I can boot normally.

I imagine you are entering the grub CLI because you get some error:
what's the error please?

no such file /gnu/store/…/bzImage.
error: try loading kernel first

That's not the exact error, but pretty close.

AFAIU (mapped-device ..(target "name") (type luks-device-mapping)))
creates the mapped device /dev/mapper/name; file-system should be:

--8<---------------cut here---------------start------------->8---

                 (device "/dev/mapper/alperton_root")
                 (mount-point "/")
                 (type "ext4")
                 (dependencies mapped-devices))

--8<---------------cut here---------------end--------------->8---

Making the this change unfortunately did not help. Once I get the system booted, the root file system is mounted correctly with both configs.

Did your configuration worked in a prior Guix System generation?

Yes, but I haven't yet had a chance to try it again with an older version of Guix.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]