[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Guix newbee

From: Jesse Gibbons
Subject: Re: Guix newbee
Date: Mon, 23 Sep 2019 07:41:12 -0600

Hi Sherab,
On Mon, 2019-09-23 at 08:30 +0000, wisdomlight--- via wrote:
> Hi
> I am interested in trying GuixSD
> I attempted it few times with no success.
> So:
> Question:
> Is GuixSD for the time being only for people who know what they're doing?
GuixSD has improved greatly since I first started using it. With the
graphical installer, you should be able to use it just fine if you're
familiar with other GNU/Linux distros.
I recommend installing the Guix package manager on another distro before
moving to full GuixSD. See "Binary Installation" in the manual[0]. You will
be able to see what packages are available and decide if your workflow can
handle full-time GuixSD. If you do install GuixSD as your main system, you
can always put another distro in a VM for packages not yet available in
> Can GuixSD be installed on Macbook Air?
If I'm not mistaken, Macbook Air has nonfree wifi. Since GuixSD is a fully
free GNU/Linux-libre distro, that would mean when you install it on your
Macbook Air (and when you wnat to update it or install additional packages)
you would need to get on the internet some other way. See "Hardware
Considerations" in the manual[1]. Installing it in a VM is a good way to
solve this problem, and can provide a fallback when something goes horribly
> Is using QEMU easy and straight forward or is it not for beginners??
I do not think QEMU is easy at all (just my opinion). I recommend using a
front end, like GNOME Boxes or Virtual Machine Manager. If you're using Mac
OSX or Windows, or it's available on whatever your main system is running,
try using VirtualBox or VMWare.

> Context:
> I tried to install Guix on my Macbook Air with a USB but this did not work
> as the system reports that:
> > loadig kernel modules
> > 
> > waiting for partition '3139370-........' to appear
> > (same message again many times)
> > usb 4-1 : device ot accepting address 2, error -62
> > 
> > waiting for partiiton '31393730-3031-.....' to appear...
> > (same message again many times)
> > ERROR: In procedure scm-erro
> > 
> > Failed to resolve partition "31393730-3031-3031-3139-
> > 343934363833"Entering a new prompt. Type `,bt` for a backtrace or `,q`
> > to continue.
> > Gnu Guiles 2.2.4
> > schem@(guile-user)> [   23.858805] usb 4-1: device not accepting
> > address3, error -6
> > usb 4-1: device not accpting address 4, error -71
> > 
> > usb 4-1: device not accpting address 5, error -71
> > 
> > usb usb4-port1: unable to enumerate USB device
> Then I tried installing via QEMU
> Following the online instructions - after initial failures I managed to
> get the VM looking like its doing something -
> I went through the graphical instlaler then downloading and building of
> package form gnu store begun.
> After 5 hours i had to abort the install.
Ouch! I'm not sure how to help you. What did you configure it to include?
> Thanks
> Sherab
> Just like an experience in a dream
> Everything I now enjoy
> Will become a mere recollection
> For what has past will not be seen again
> Sent from [ProtonMail](, encrypted email based in
> Switzerland.
> Sent with [ProtonMail]( Secure Email.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]