[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: guix system reconfigure doesn't work, guix system: error: python-pep

From: contact
Subject: Re: guix system reconfigure doesn't work, guix system: error: python-pep8
Date: Sun, 24 Nov 2019 08:49:34 +0000
User-agent: Roundcube Webmail/1.3.10

Le 2019-11-23 17:26, Oleg Pykhalov a écrit :
Hi, writes:

I have tried to launch again some guix pull, guix package -u but
whithout success...

Try ‘hash guix’ command after ‘guix pull’.  Also post a ‘guix describe’
output here, please.

Hi Oleg ;-)

Thank you, it has worked ! When I launched $ guix describe the description was:

$ guix describe
Génération 39   23 nov. 2019 21:44:07   (actuelle)
  guix e8f8637
    URL du dépôt :
    branche: master
    commit : e8f863704549445aeace0226bd0028e15d0eec5b

Today, it's exactly the same description. I'm running Linux gnu 5.3.12-gnu :-)

After guix pull, the guix hash command has apparently been successfully launched (no error message).

Then, when thinking to your suggestion to guix describe, I decided to '$ sudo guix system reconfigure /etc/config.scm' instead of '# guix system reconfigure /etc/config.scm' (... which was not working) (Even after a '$ guix hash') And it seems to work now...

Maybe, it was not a good practice to launch the reconfiguration always under the root account. It was my case and I'll consider the sudo option now.

Thanks again for your answer, which was concise and inspiring.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]