[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Can I easily install GNU Emacs 27.1.50 via Guix?

From: zimoun
Subject: Re: Can I easily install GNU Emacs 27.1.50 via Guix?
Date: Fri, 18 Dec 2020 10:00:33 +0100


On Fri, 18 Dec 2020 at 15:03, Carlo Zancanaro <> wrote:
> On Fri, Dec 18 2020, zimoun wrote:
>>> When I launch Debian's Evince from Guix's emacs-maint, Evince 
>>> cannot find my local printer.  Look at the messages when I open 
>>> Evince in an Emacs shell and open Evince's print dialog:
>> Well, it seems expected, isn’t it? ...
> I don't think "expected" is the right way to put this. I think 
> "explainable" is more accurate. I think it's reasonable to expect 
> that opening Debian's Evince from within Emacs would be able to 
> find the printers. The fact that it cannot is a bug introduced by 
> Guix's use of environment variables.

Maybe I miss something and I have not dove into all the details so I
could be totally wrong.  However, from my understanding, A is built
against the shared library C1, and B is built against the shared library
C2, and nothing says that C1 and C2 are compatible.  If you run A inside
B, then C2 is used for both A and B, and A fails because it expects C1
and finds instead C2.  I miss why it is considered as a bug.  Aside the
fact that A and C1 are system-wide so without any control on how it is

>From my understanding, it is a bug if A built against C2 run inside B
built too against C2 does not work; which correspond to:

      guix environment --pure --ad-hoc emacs evince
      emacs -q -f shell

    and type “evince”.

    Then I do not have any error when I open the print dialog; but I have no
    setup for CUPS on my machine though.

And it appears to me also a bug if:

  guix environment --pure --ad-hoc emacs-no-x
  emacs -q -f shell

and type “/usr/bin/evince” where the print dialog fails.  On my machine,
it is not the case; but I have no setup for CUPS on my machine though.

Otherwise, from my point of view, failure should happen and I miss why
it should be considered as a bug, but as I said, I should probably miss
something and be wrong.

> I run into a similar problem where my window manager (awesomewm) 
> sets LD_LIBRARY_PATH, which then propagates to everything I run 
> from my session. It's quite a pain. I thought there was an open 
> issue for this, but I can't seem to find it at the moment.

On foreign distro or Guix System?

All the best,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]