[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Getting Guix System to use llvmpipe

From: raingloom
Subject: Re: Getting Guix System to use llvmpipe
Date: Tue, 12 Oct 2021 22:09:10 +0200

On Tue, 12 Oct 2021 12:52:46 -0400
Philip McGrath <> wrote:

> Hi folks,
> I'm trying to install Guix System on real hardware for the first
> time, and I'm having some graphics trouble.
> The machine has an older Asus M5A78L-M/USB3 motherboard with an
> onboard Radeon HD 3000 GPU---the R600 family, IIUC, so covered by the
> `radeon` driver rather than `amdgpu`. I understand that functionality
> will be limited since I'm not using nonfree firmware, and I can live
> with that.
> I've tried Debian 11 on this board (without "nonfree"), and, after 
> noting the missing firmware, it falls back to work acceptably with 
> `llvmpipe`.
> Unfortunately, Guix System is working less well. When it starts the 
> display manager (I've tried both GDM and SDDM, with both X11 and 
> Wayland), the screen goes blank permanently, and the logs show that 
> starting the X server fails: initially with an error about an
> undefined symbol `exaGetPixmapDriverPrivate`, though through various
> incantations on the kernel command line or in the X configuration I
> can produce other errors, like "X: ../include/privates.h:121:
> dixGetPrivateAddr: Assertion `key->initialized' failed."
> Can I configure Guix to give up on the missing firmware and just use 
> `llvmpipe`, as Debian does?
> Or, of course, if there's something even better I should do, I'd be
> glad to hear about that!
> Thanks,
> Philip

Just a hunch but maybe you could blacklist the broken firmware on the
kernel command line arguments. I think it's something like
modprobe.blacklist=radeon,amdgpu? Sorry, I can't look into it more
right now, but that should give you some keywords to search for and
maybe find the proper docs.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]