[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

No sound - Intel HDA SOF driver and Nvidia HDMI

From: Mameka
Subject: No sound - Intel HDA SOF driver and Nvidia HDMI
Date: Mon, 25 Oct 2021 22:57:12 +0000

I installed Guix System on my ASUS TuF Gaming 705 GM notebook. There is an 
Intel / Nvidia Optimus graphics card. The sound modules are Intel HDA and 
Nvidia HDMI. After a normal boot the Nvidia HDMI is activated and I don't hear 
any sound out of the speakers. Only the "dummy driver" is loaded.
If I plugin an USB sound card this works fine. But I like to use the internal 
sound card.

Some logs:

        cat /proc/asound/card*/codec* | grep Codec Codec: Nvidia GPU 84 HDMI/DP 
sudo dmesg | grep -i snd_hda_intel [ 29.243097] snd_hda_intel 0000:00:1f.3: DSP 
detected with PCI class/subclass/prog-if info 0x040380 [ 29.243111] 
snd_hda_intel 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF 
driver [ 29.243171] snd_hda_intel 0000:01:00.1: enabling device (0000 -> 0002) 
[ 29.243267] snd_hda_intel 0000:01:00.1: Disabling MSI [ 29.243270] 
snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client [ 29.725366] 
snd_hda_intel 0000:01:00.1: bound 0000:01:00.0 (ops 
nv50_audio_component_bind_ops [nouveau]) lspci | grep -i audio 00:1f.3 Audio 
device: Intel Corporation Cannon Lake PCH cAVS (rev 10) 01:00.1 Audio device: 
NVIDIA Corporation GP106 High Definition Audio Controller (rev a1) I tried 
Trisquel 9 before Guix and there the sound was working fine. Trisquel uses the 
Libre Kernel as well, so I hope that Guix System can do it also. I tried to 
blacklist the snd_hda_intel in the /etc/config.scm (use-modules (gnu)) 
(use-service-modules desktop networking ssh xorg) (use-modules (gnu services 
virtualization)) [...] (kernel-arguments 
'("modprobe.blacklist=nouveau,snd_hda_intel,snd-hda-intel")) [...] 
(supplementary-groups '("wheel" "netdev" "audio" "video" "libvirt" "kvm"))) 
[...] Unfortunately this does not work. I get no sound. Blacklisting the 
snd_hda_intel worked in Slackware and Debian. Any advice is welcome. Kind 
regards, Mameka

reply via email to

[Prev in Thread] Current Thread [Next in Thread]