[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: downgrade issue on guix system

From: Alexander Asteroth
Subject: Re: downgrade issue on guix system
Date: Sat, 27 Nov 2021 11:36:40 +0100
User-agent: mu4e 1.6.10; emacs 27.2

Dear all,

just to close this thread...

The fault was to "sudo -s" to reconfigure the system which did not
comletely set all neccessary variables (guix was pulled into roots
profile but run from users profile).

Either *really* logging in as root or probably much better (which I do
now) just "sudo guix system reconfigure ..." resolves the issue (because
the path to guix refers to the correct location in either cases).

Thank's Julien for pointing me into the right direction.



On Thu, Nov 25 2021, 07:23:03, Julien Lepiller <> wrote:

> Le 25 novembre 2021 07:06:19 GMT-05:00, Alexander Asteroth 
> <> a écrit :
>>No I did not play around with branches. What I did was
>>- changed my config
>>- reconfigured
>>- rebooted
>>- failed
>>- booted second last config
>>- fixed config
>>- reconfigured
>>- rebooted
>>- OK
>>- pulled
>>- added cups
>>- reconfigured
>>---->>> ERROR
>>I just tried again. Did a
>>GUIX_PROFILE="~/.guix-profile" &&      . "$GUIX_PROFILE/etc/profile"
>>hash guix
>>guix system reconfigure .../config.scm
> This is not enough: you need to also load the "current" profile. Check the 
> output of "type guix" too.
>>Same error.
>>Is there a way to find out what goes wrong? And why I have something
>>installed that is newer than what I get over the guix channel?
> I think this is because you're not actually running guix from the latest you 
> pulled. Make sure it's running from ~/.config/guix/current, not 
> ~/.guix-profile nor /var/guix.
> This should already be taken care of by default, but if this is your first 
> guix pull you might need a reboot (or at least log out, and in again).
>>-- Alex
>>On Thu, Nov 25 2021, 06:53:59, Julien Lepiller <> wrote:
>>> Hi Alexander,
>>> Since you did a guix pull, you should have a newer version of guix than you 
>>> had before, unless you played with branches. So the downgrade is worrying 
>>> and you were right to stop there.
>>> Note that running guix pull will update guix in a separate profile. Make 
>>> sure it's loaded: that you have ~/.config/guix/current/bin in your path and 
>>> that "type guix" is this path. If not, fix
>>> your $PATH and run "hash guix" (no output) and check again.
>>> Note that, if you're running reconfigure as root (instead as with sudo) 
>>> you'll need to pull and do the above as root, since each user has a 
>>> different guix current profile.
>>> HTH!
>>> Le 25 novembre 2021 06:38:29 GMT-05:00, Alexander Asteroth 
>>> <> a écrit :
>>>  Dear all,
>>> I just wanted to install cups service on my guix system. I recofigured
>>> the system without an error one hour ago (introduced seperate home
>>> filesystem) and now, when I try to add the cups service (I did a guix
>>> pull in between as well) I get:
>>>  guix system: error: aborting reconfiguration because commit 
>>> bd2aa8031babdca5f574fca52e025d6794f08d82 of channel 'guix' is not a 
>>> descendant of
>>>  7f974548ac20cab88b9bb589a5e1d85ee3b8d337
>>> hint: Use `--allow-downgrades' to force this downgrade.
>>> I have no clue what caused that error therefor I also don't know if it's
>>> a good idea to allow downgrades. ... or what es to do to resolve the
>>> issue.
>>> Cheers,
>>> Alex

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]