[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: emacs-shroud package appears to be out of date

From: Maxim Cournoyer
Subject: Re: emacs-shroud package appears to be out of date
Date: Thu, 13 Jan 2022 15:30:44 -0500
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.2 (gnu/linux)

Hello Gary,

Gary Johnson <> writes:

> Hi Guix,
> During my recent `guix pull` + `guix package -u` adventure, the
> emacs-shroud package barfed due to what looks like a hard-coded
> reference to an older version of gnupg. I uninstalled it in order to
> complete my upgrade. Of course, when I try to reinstall it now, I
> continue to get the same version conflict error due to gnupg.
> ```
> gjohnson@euclid ~ $ guix package -i emacs-shroud
> The following package will be installed:
>    emacs-shroud 1.105
> guix package: error: profile contains conflicting entries for gnupg
> guix package: error:   first entry: gnupg@2.2.30 
> /gnu/store/0snfzd41n430ddpq316j9v2z5fn2y62m-gnupg-2.2.30
> guix package: error:    ... propagated from emacs-shroud@1.105
> guix package: error:   second entry: gnupg@2.2.32 
> /gnu/store/75122spwjdkxxgd32gkkil3n7ifax8i5-gnupg-2.2.32
> guix package: error:    ... propagated from emacs-pinentry@0.1-1.dcc9ba0
> hint: Try upgrading both `emacs-shroud' and `emacs-pinentry', or remove one 
> of them from the profile.
> ```
> Note, that while the above error message is complaining about
> emacs-pinentry, it still barfs even if I remove emacs-pinentry and just
> install gnupg directly since the current gnupg is 2.2.32.
> Can whoever is maintaining the emacs-shroud package please update it to
> gnupg@2.2.32, so it can be installed again?

This will be fixed shortly when version-1.4.0 gets merged to master in a
few days, where gnupg == 2.2.32.

Thanks for the report, and thank you for your patience.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]