[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Stuck at scheme prompt when booting

From: Ricardo Wurmus
Subject: Re: Stuck at scheme prompt when booting
Date: Sat, 12 Feb 2022 23:08:47 +0100
User-agent: mu4e 1.6.10; emacs 27.2

coralgoat--- via <> writes:

> I have some more information to add to my initial message.
> I have opened the computer to make sure the hard drive has a good
> connection to the motherboard and it does.
> I have also tried typing `,bt` at the "scheme@(guile-user)>" prompt
> the output is included below.  Note  there is a solid white square 
> single character symbol in the output and I am representing it as
>  "***" in the output below.
> The line in the output that catches my attention is:
> "1 (copy-file "/etc/static/resolv.conf" "/etc/resolv.conf")"

This file is generated every time Guix System boots.  Most of the system
is instantiated anew on every boot.  This also includes creating user

Having a file there that cannot be modified is indeed the problem here.

> I think that if I ran the command `chattr -i /etc/resolv.conf` it
> might fix the problem and allow the system to boot however I get an
> error when I try typing that at the scheme prompt.
> Any suggestions on how I should get a Linux console terminal so I can
> enter the `chattr -i /etc/resolv.conf` command?

  (system* "/gnu/store/…-bash/bin/bash")

but for that to work you’d have to know the hash.  Dependent on how far
along the boot process has come along you may already have
/run/current-system/profile/bin/bash, so try

  (system* "/run/current-system/profile/bin/bash")

This gives you a proper shell.

You may also have chattr in that location, so you could do this

  (system* "/run/current-system/profile/bin/chattr" "-i" "/etc/resolv.conf")


reply via email to

[Prev in Thread] Current Thread [Next in Thread]