[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: attempt to create a profile

From: Gottfried
Subject: Re: attempt to create a profile
Date: Sat, 11 Feb 2023 16:20:29 +0000


I wanted to create a profile with "Musescore 3.6"
but 3 times it failed during building process.

So I had to create the profile with "Musescore 4".

Now I have Musescore 4 in my main profile and in my Musescore profil.

So the problem is now, how do I know when opening "Musescore" which one will open.
Using the menu it opens "musescore 4" in my main profile
Using an icon it opens "musescore 3.6" the earlier version, which I need as well.

if I enter "musescore" in my bash
it doesn’t open this package.
If this profile is open/sourced, it should open this package.
Other packages from my main profile like icecat, gedit, pluma open immeadiately.

Today, without doing anything
I did a:
guix package -p /home/gfp/Projekte/Musescore/guix-profil

and the outcome was:

gfp@Tuxedo ~$ guix package -p /home/gfp/Projekte/Musescore/guix-profil --list-installed
musescore       4.0     out     
gfp@Tuxedo ~$
This means I was already in this profile, or better to say, both profiles were open at the same time
without sourcing it today.

This means for me that, when I tried to source this profile earlier,
I opened it, but didn’t manage to close it.

Is it better to close it, or leave several profiles open at the same time?

Is it a problem when both/more profiles are always open?

what does it mean for my bash/MATE terminal?
Shouldn’t I be able to open "musescore" in both profiles?
Is so, what do I have to enter in the bash to open this or that "musescore"

I am hacking on the very basics

Kind regards


Am 09.02.23 um 20:20 schrieb Csepp:

Gottfried <> writes:

[[PGP Signed Part:Undecided]]

thanks for your help.

I tried to open this profile,


gfp@Tuxedo ~$  source /home/gfp/Projekte/Musescore/guix-profil/etc/profile


gfp@Tuxedo ~$ guix shell -p /home/gfp/Projekte/Musescore/guix-profil

but it didn’t happen anything.

It's normal, it normally doesn't show anything.

How can I know, that I am now in this profile?

Shouldn’t bash show me something?

If you directly source the etc/profile script, GUIX_PROFILE does not get
defined, so bash doesn't know you loaded a profile.
Which is actually "correct", since sourcing it is not the same as
entering it using guix shell/environment.  Sourcing directly modifies
the running process's environment variables, so exiting bash would not
get you back to a default environment, it would most likely just close
the terminal emulator.  But if you are in a genuine `guix shell`,
running the exit builtin command gets you back to the process where guix
shell was run from.

If you used guix shell then I'm pretty sure it should show someting.
Running `guix shell -p ~/.guix-profile -- bash` does show the [env]
prompt for me, so either your bash is configured differently or your
login shell is not bash.  For example, my login shell is Zsh, which
doesn't have the same customization, I had to add a similar prompt hack

And when I opened the package "musescore" it opened the package
musescore in my other profile.
So I guess I am not in this profile.

Did you open it from bash or from a desktop app launcher?
The environment variables are only changed locally in the bash process
you ran source from, or the bash process that guix shell spawned.
If you did run it from there and it launched the wrong one, then could
you post the output of

guix package -p /home/gfp/Projekte/Musescore/guix-profil --list-installed


Maybe you accidentally mixed up which version is installed in which
profile, it happens.


Attachment: OpenPGP_0x61FAF349C9FB7F94.asc
Description: OpenPGP public key

Attachment: OpenPGP_signature
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]