[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Help-mcsim] Emacs info again?

From: Bill Harris
Subject: Re: [Help-mcsim] Emacs info again?
Date: Sun, 25 Mar 2018 10:59:17 -0700

Oops.  I did "sudo install-info ." (well, I was in the right directory, so . is the "dir" into which I want to install, right?  I guess not.)

That did the job.  Thanks!

I'll ignore xmcsim (I think I've tried it only once or twice, so it's not a huge loss.  I seem to recall a bit of time savings in doing quick exploratory graphs, but that's been years ago, so I may be mis-remembering.)

And I do know where my examples directory is, so that's no problem.


On Sun, Mar 25, 2018 at 10:25 AM, fredomatic <address@hidden> wrote:
Yes, the doc, examples, xmcsim directories are not installed in share/.
Not sure that too many people would find them there. And XMCSim needs
some cleaning up (I think that nobody uses it :-(

For install-info, you should first copy in /usr/share/info
and from that directory do (exactly)
"sudo install-info dir"
dir is not a directory, it is actually the info directory file (you
should check before that it exists). It's kind of stupid to call a file
"dir" and that makes the man pages for install-info rather confusing.


On 25/03/2018 17:19, Bill Harris wrote:
> tl;dr: I can create the info file, and it works, but install-info fails,
> and I think I found the issue.  In addition, xmcsim doesn't seem to get
> installed, and there eis no examples dir  in /usr/local/share/mcsim (but
> that may be correct).
> Step 1: Yes, *info* is in /usr/share/info.
> Step 2: I thought my mcsim/doc directory would be in /usr/local/share/,
> but that only contains mod and sim.  I  searched to see if it could be
> elsewhere, but it isn't:
> /usr$ find . -name mcsim* -print
> ./local/share/mcsim
> Is that a problem?  I had thought I might have directory entries there
> for doc, examples, and perhaps even xmcsim.
> I still have the directory in my home directory where I built it, and I
> did run makeinfo mcsim.texi  yesterday in that doc directory.  Since the
> argument to makeinfo appears to be the input file and my doc directory
> contains mcsim.texi, I figured that was correct.  It created a
> <> file in that same directory.  I think
> that worked, because I can run `info mcsim` in that directory and get
> what looks like a valid info session.
> Step 3: I did not know or at least remember the install-info command.  I
> should have tried the C-u C-h i trick, though; info works from there, too.
> Running that command failed:
> /usr/share/info# install-info <> .
> install-info: .: empty file
> Reading
> made it sound like the <> file needed
> @dircategory and @direntry, but I don't see them in the file.  Is that
> perhaps the issue?
> One more issue: While I haven't used xmcsim much in the past, I tried
> it, and it doesn't seem to work:
> /usr$ find . -name xmcsim -print
> $ xmcsim
> bash: xmcsim: command not found
> /usr$ 
> FYI, and thanks for your quick reply.  I /think/ I did the install
> according to the instructions, but feel free to point out mistakes I may
> have made.
> Bill
> On Sun, Mar 25, 2018 at 12:35 AM, fredomatic <address@hidden
> <mailto:address@hidden>> wrote:
>     Hi Bill,
>     I will look into why it's still not done automatically. For now you can
>     do a few things:
>     - find where your info directory is (in emacs do "C-h i" and then
>       "C-x C-f", that should do). Typically that is /usr/share/info.
>     - Then in your mcsim/doc directory do "makeinfo mcsim.texinfo" if you
>       have not done it already
>     - Then "sudo install-info <>
>     /usr/share/info/dir" (the dir file
>       in your info directory.
>     That will make a permanent link to the
>     <> file in the info dir
>     file. Now whenever you type "info mcsim" that should bring you there, or
>     if you type just "info" mcsim will appear in the GNU Packages section.
>     Rather than leaving <> in mcsim/doc you
>     may want to sudo copy it
>     to the info directory and do sudo install-info in that directory.
>     For emacs: I'm not using info from there, so I'm not the best adviser,
>     but if you do "C-u C-h i" it will ask you which info file to read. If
>     you are already in info (C-h i) it will propose the system info
>     directory. So if you have copied <>
>     there that would be quick.
>     There is also a couple of emacs variables you can set to find it more
>     quickly.
>     Best regards
>     Frederic
>     On 24/03/2018 17:59, Bill Harris wrote:
>     > Fifteen months ago, I got help here installing Emacs info for MCSim
>     > 5.6.5
>     > (
>     <>). 
>     > Now I'm curious about the same question for 6.0.0 on Debian 9.
>     >
>     > As root, I ran makeinfo mcsim.texi in my local copy of the doc directory
>     > (~/bin/mcsim-6.0.0/doc/), and it produced a <>
>     > <> file in that directory.  I cd'd up one level
>     and ran
>     > make install.  Even after restarting *info*, I see no mcsim entry, and
>     > /usr/local/share/mcsim only has mod and sim directories.
>     >
>     > Is there somewhere else I should look?  Is there something else I should
>     > do?  I have a vague recollection from the past that it just used to
>     > work, so I'm reluctant to start moving files and editing *info* indices
>     > manually unless someone convinces me that's the right way to go.
>     >
>     > BTW, 6.0.0 looks like a major advance over 5.6; thanks!
>     >
>     > Bill
>     > --
>     > Bill Harris                   
>     >
>     <>
>     >
>     >
>     > _______________________________________________
>     > Help-mcsim mailing list
>     > address@hidden <mailto:address@hidden>
>     >
>     <>
>     >
> --
> Bill Harris                   

Bill Harris          

reply via email to

[Prev in Thread] Current Thread [Next in Thread]