[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Help-nano] Segfaults in libc-2.19 w/ 2.9.2

From: Andreas Schamanek
Subject: Re: [Help-nano] Segfaults in libc-2.19 w/ 2.9.2
Date: Mon, 22 Jan 2018 01:53:30 +0100 (CET)
User-agent: Alpine 2.21.9 (DEB 218 2017-09-23)

Hi everyone,

After several hours editing the file where I experienced the last crash, this time, without any problems I eventually managed to provoke another segfault. As Benno suggested, I tried to reproduce the exact same scenario, and it worked! It's that rare moment of great joy where for once you are actually glad the program crashes ;)

I haven't yet recompiled nano with Brand Huntsman's patch, however, I was able to narrow the crash scenario down quite a bit (at least on my system) and wanted to share this already. Maybe the bug is apparent, anyway:

1) Make a backup of .nanorc: `mv .nanorc .nanorc.bak`
2) Create .nanorc with only `set trimblanks`, e.g with

   echo set trimblanks >~/.nanorc

3) Start nano without any options: `"nano"`
4) Type (copy-paste)

12345678901234567890123456789012345678901234567890123 x 1234567890123

5) Place cursor behind x (position 56) and type the following keys

  1 2 3 space 4 5 6

6) When hitting space the text at the end of the line ("1234567890123")
will wrap. When typing 5 the crash occurs, in my case e.g.

  kernel: [695546.591499] nano[32523]: segfault at 25bafff ip
  00007fe77bfbefdd sp 00007ffdf7f0e228 error 4 in[7fe77be86000+1a1000]

-- Andreas


reply via email to

[Prev in Thread] Current Thread [Next in Thread]