[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

"vform" problem when compiling

From: John W. Eaton
Subject: "vform" problem when compiling
Date: Fri, 3 Mar 2000 01:00:42 -0600 (CST)

On  3-Mar-2000, address@hidden <address@hidden> wrote:

|       I suffer from the following problem when building either 2.0.16 or
| 2.1.28 on Solaris x86 7 :
| c++  -I. -I.. -I../liboctave -I../src -I../libcruft/misc  -I../glob -I../glob 
-DHAVE_CONFIG_H -mieee-fp -fno-rtti -fno-exceptions -fno-implicit-templates -O 
-rdynamic \
| -L..   -fPIC -g -o octave \
| octave.o builtins.o ops.o  balance.o  besselj.o  betainc.o  chol.o  colloc.o  
dassl.o  det.o  eig.o  expm.o  fft.o  fft2.o  filter.o  find.o  fsolve.o  
gammainc.o  getgrent.o  getpwent.o  getrusage.o  givens.o  hess.o  ifft.o  
ifft2.o  inv.o  log.o  lpsolve.o  lsode.o  lu.o  minmax.o  pinv.o  qr.o  quad.o 
 qz.o  rand.o  schur.o  sort.o  svd.o  syl.o  time.o \
| -L../liboctave -L../libcruft -L../src  \
| ../src/liboctinterp.a ../liboctave/liboctave.a  ../libcruft/libcruft.a  
../readline/libreadline.a ../kpathsea/libkpathsea.a ../glob/libglob.a  \
| -lg2c -lm  -L/usr/ccs/lib -L/usr/lib 
 -L/usr/ccs/bin -L/usr/ccs/lib 
-L/opt/gnu/lib/gcc-lib/i386-pc-solaris2.7/2.96/../../.. -lm  -lcurses -ldl 
-lsocket -lm 
| c++: unrecognized option `-rdynamic'
| Undefined                       first referenced
|  symbol                             in file
| ostream::vform(char const *, char *)../src/liboctinterp.a(error.o)
| ld: fatal: Symbol referencing errors. No output written to octave
|     I have tried gcc 2.95.1 and the 20000221 gcc snapshot with the
| same result.  I don't know why it thinks the second argument here
| should be "char *" rather than va_list.  I'm tempted to change the
| call to vsnprintf and give it a huge buffer (but I'd rather not).
|       Has anyone seen this before ?

Not for a long time.  In the past, this sort of problem was usually
due to an incorrect g++ installation.  Is it possible that you somehow
used the system C compiler for some of the configure tests when you
built gcc?  That could have resulted in deciding that va_list is char*
instead of whatever type gcc expects it to be on your system.


Octave is freely available under the terms of the GNU GPL.

Octave's home on the web:
How to fund new projects:
Subscription information:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]