[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Weird error with gnuplot: 'invalid command'

From: John W. Eaton
Subject: Weird error with gnuplot: 'invalid command'
Date: Tue, 12 Apr 2005 10:26:17 -0400

On 12-Apr-2005, Alexander Klink <address@hidden> wrote:

| when I try to plot something using gnuplot, I get the following
| error:
| gnuplot> '/tmp/oct-kpni5m'  ""  lines 1  set grid ; set xlabel
| "Matchingscore" set ylabel "Normierte Haeufigkeit" set title
| "Haeufigkeitsverteilung Keine Brille, Kein Bart Algorithmus 7" set
| nologscale ;set nopolar ; '/tmp/oct-mwSCLt'  ""  lines 1  set nologscale
| ;set nopolar ; '/tmp/oct-w19cMD'  ""  lines 2
|          ^
|                 line 0: invalid command
| I tried to isolate the error and reproduce it, but no luck: when I
| use only the relevant commands and put them in a seperate file,
| octave run's just fine. The working version looks something like
| this:
| grid on
| xlabel('test x')
| ylabel('test y')
| title('title')
| gset term postscript color
| gset output "/tmp/test.eps"
| edges = 0:0.025:1
| impostor = [ ... ]
| genuine = [ ... ]
| plot(edges, impostor, 'r')
| hold on
| plot(edges, genuine, 'g')
| hold off
| replot
| Anything I might have forgotten in code further up that influences
| these commands to throw the error? Or any idea how to debug this
| further? I tried setting the gnuplot_binary to something like 
| 'cat > /tmp/log', but that did nothing at all :-/
| I'd appreciate your help.

What version of Octave are you using?  There have been some recent and
significant changes to the way Octave interacts with gnuplot, so the
version probably matters.  And in any case, when reporting problems
with software, it is a good idea to supply information like that if
you would like people to have a reasonable chance of being able to
help you.


Octave is freely available under the terms of the GNU GPL.

Octave's home on the web:
How to fund new projects:
Subscription information:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]