[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Gnuplot error in Octave

From: Niner
Subject: Re: Gnuplot error in Octave
Date: Fri, 18 Jan 2008 16:06:03 -0800

Hi Thomas,

My problem is solved. I answered your questions below. Thank you very much.


On Jan 18, 2008, at 3:45 PM, Thomas Treichl wrote:

Niner schrieb:
Hi Thomas,
I install from the same package of Octave.dmg, which I download from Octave-Forge. I place these two app in the / Applications folder. Octave automatically finds gnuplot to plot, but I got error on gnuplot. I also made link to Octave and Gnuplot such that I can open them whenever I need in
The result of which gnuplot is
where is the link pointing to.
Thanks for your response.

No problem.

I think you have one of the problems that some users already reported. Something on their Mac influences and further tells to use some strange backend driver. In your case this is 'aquax' and I don't know who/what wants to set aquax for Gnuplot. I may copy a summary from an older email here to not must rewrite everything new, please check (and give feedback) if one of these settings match your criteria:

- The only thing that I can see and I don't know what it is for is the manual installation of AquaTerm - an installation of AquaTerm is not required if using the that comes with the octave- *.dmg. brings its own working AquaTerm framework that is installed in /Applications/ Maybe the problem comes with that!
Do I need to uninstall

- Can you see a .gnuplot file in your home directory? If yes what's in it?
   MyMac:~$ cat ~/.gnuplot
No. I didn't find .gnuplot file in my home directory. Should I need to create one?

- If you do
   MyMac:~$ export GNUTERM=aqua
   MyMac:~$ /Applications/
   gnuplot> plot sin(x)/x
 is the bug still there?
No bug. After export GNUTERM=aqua, the gnuplot use terminal "aqua" as default and works find. The plotting is right.

- gnuplot provides the x11 terminal type for use with X servers. This
terminal type is set automatically at startup if the DISPLAY environment variable is set, if the TERM environment variable is set to xterm, or if
the -display command line option is used.
In my case is, if I run octave in, not xterm, the plot in octave went wrong when calling gnuplot. But now it works fine after I export GNUTERM=aqua. I added this line into my bash .profile file.

- If GNUTERM is defined, it is used as the name of the terminal type to be used. This overrides any terminal type sensed by gnuplot on start- up, but is itself overridden by the .gnuplot (or equivalent) start-up file (see
start-up (p. 34)) and, of course, by later explicit changes.

- On Unix, HOME is used as the name of a directory to search for a
.gnuplot file if none is found in the current directory.

- GNUPLOT_LIB may be used to define additional search directories for data and command files. The variable may contain a single directory name, or a list of directories separated by a platform-specific path separator, eg.
’:’ on Unix, or ’;’ on DOS/Windows/OS/2/Amiga platforms. The contents
of GNUPLOT LIB are appended to the loadpath variable, but not saved with
the save and save set commands.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]