[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

can't install octcdf-1.0.13 package

From: Thomas Detman
Subject: can't install octcdf-1.0.13 package
Date: Mon, 04 Apr 2011 18:24:53 -0600
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20110223 Lightning/1.0b2 Thunderbird/3.1.8

I love octave!

I just upgraded my Lenovo T61 Linux notebook from Ubuntu 8.04LTS to 10.04LTS.
I had installed octave with the Synaptic Package Manager under 8.04. The upgrade automatically tried to upgrade my octave to octave-3.2.3 in the process, but failed with error message ~ "subprocess installed post-installation script returned error exit".
Package octave-3.2 failed to install or upgrade.  I clicked [report to 

After rebooting into Ubuntu 10.04, I still had octave-3.0.

I may have messed things up long ago. I originally had octave-2.9, and with it the package octcdf-1.0.7, and it worked. But to get around a graphics bug in 2.9, I had downloaded and installed separately octave-3.0. I tried but failed to install the octcdf package into my octave-3.0. So I kept and used both.
(I'm only 90% sure of those version numbers.)

After the OS upgrade, I used Synaptic to upgrade octave to 3.2.3, and that succeeded. But when I tried to install the octcdf-1.0.13 package with Synaptic, I ran into problems. Synaptic seemed to be successful, but when I ran octave, it told me the octcdf package was not installed (pkg list).

I used Synaptic to see what files it installed, and looked at some of the new "tree" branches; they were there.

I tried several things with the pkg command, but got nowhere.

I think my octave-3.2.3 file tree or configuration must be messed up, but I don't really know what's wrong or how to fix it. (Help)

I suppose I could download the octcdf-1.0.13.tar.gz package and use pkg install to try to install it that way; that might work, but it is a work around and does not fix the underlying configuration(?) problem.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]