[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: filtfilt error solved?

From: seektime
Subject: Re: filtfilt error solved?
Date: Fri, 3 Feb 2012 09:36:14 -0800 (PST)

Hi Muhali,

Thanks for your reply. I'm not sure how to install 3.6 on my Windows
machine? Have you compiled it yourself, or does an installer exists?

Thanks again,

On Fri, Feb 3, 2012 at 9:20 AM, Muhali [via Octave]
<[hidden email]> wrote:

> seektime wrote
> octave:129> [b, a]=butter(3, 0.1);
> octave:130> t = 0:0.01:1.0;
> octave:131> x=sin(2*pi*t*2.3)+0.25*randn(size(t));
> octave:132> y = filtfilt(b,a,x);
> error: filter: first dimension of SI must be of length max (length (a),
> length (b)) - 1
> error: called from:
> error:
> C:\Octave\3.4.3_gcc-4.5.2\Octave3.4.3_gcc4.5.2\share\octave\packages\si
> gnal-1.1.1\filtfilt.m at line 85, column 3
> It works (for me) with octave-3.6 and signal-1.1.2
> M.
> ________________________________
> If you reply to this email, your message will be added to the discussion
> below:
> To unsubscribe from filtfilt error solved?, click here.

View this message in context: Re: filtfilt error solved?
Sent from the Octave - General mailing list archive at

reply via email to

[Prev in Thread] Current Thread [Next in Thread]