[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Octave on Mac and Java

From: David
Subject: Re: Octave on Mac and Java
Date: Tue, 12 Jul 2016 11:27:40 +0100
User-agent: Microsoft-MacOutlook/

Sorry Sebastian, didn’t realise you were suggesting one or the other approach, 
my mistake. 

I don’t have much command line experience with the Mac… although was a 
programmer in a previous life… I ran the command 

brew install homebrew/science/octave --with-java

... otherwise it was complaining about not finding octave

Full output is:

macTaff:local David$ brew install homebrew/science/octave --with-java
==> Tapping homebrew/science
Cloning into '/usr/local/Library/Taps/homebrew/homebrew-science'...
remote: Counting objects: 606, done.
remote: Compressing objects: 100% (604/604), done.
remote: Total 606 (delta 1), reused 63 (delta 0), pack-reused 0
Receiving objects: 100% (606/606), 519.92 KiB | 0 bytes/s, done.
Resolving deltas: 100% (1/1), done.
Checking connectivity... done.
Error: Invalid formula: 
undefined method `with_qt?' for #<Class:0x007fa1740e9030>
Error: Cannot tap homebrew/science: invalid syntax in tap!

I only installed homebrew for the first time a few hours ago, so assuming no 
problems there.

Thanks for your assistance!

On 12/07/2016, 10:42, "Sebastian" <address@hidden> wrote:

>>> As Ben said, out does not ship with Java support. You have to 
>>> build Octave by you own, e.g.
>>> 1) install Octave from homebrew, e.g. "brew install octave --with-java". 
>>> Probably something similar works for Macports.
>>> 2) use the steps explained here 
>>> I 
>>> modified the script "" to take as an additinal option 
>>> "-j". It should compile Octave with Java 1.6.0.
>There is a misunderstanding: you can either do 1) OR 2). Actually, approach 2) 
>is doing 1) in the particular install directory /Application/ 
>(instead of /usr/local) with many additional steps that are necessary to 
>arrive at a nice disk image.
>> The brew install falls over complaining about “with-qt”… I’ve reinstalled qt 
>> to be sure, and tried adding a —-with-qt=5 suffix to the command, to no 
>> avail.
>What is the error message exactly? Are we talking about "brew install 
>gnuplot"? Maybe you should uninstall homebrew and start from scratch...
>> I tried the latter step yesterday… not realising perhaps I needed to do the 
>> former first... which progressed for 9 hours before collapsing with a 
>> cryptic error about sourceforge!
>As mentioned before, approach 2) can be done independent of 1). If you are an 
>experienced command line user and you do not need an app-bundle then approach 
>1) is totally sufficient. 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]