[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Help-smalltalk] re: compiling gst 2.1.8 on darwin

From: jerry mead
Subject: Re: [Help-smalltalk] re: compiling gst 2.1.8 on darwin
Date: Thu, 4 Nov 2004 15:51:02 +0100

I tried this but got the following message:
        make  all-recursive
        Making all in lib-src
make[2]: *** No rule to make target `poll.h', needed by `all-am'. Stop.
        make[1]: *** [all-recursive] Error 1
        make: *** [all] Error 2
so apparently 'poll.h' is listed as required somewhere. That's why I copied that into the lib-src directory. Presumambly that reference just has to be removed.

Now I've removed the references to poll.h in lib-src/ and lib-src/ and all goes well until the I receive the following output from executing make:

           cd $builddir && \
           $builddir/order -v path="`pwd`" ./placer.h) > $builddir/.order
        awk: nonterminated character class .+[^
          source line number 53
          context is
                           if (path ~ >>>  /.+[^/ <<< ]$/)

if I run make again this message doesn't appear but I get an error as follows (in gtk)

ar cru .libs/gst-gtk.a  gst-gtk.o placer.o
ranlib .libs/gst-gtk.a
(cd .libs && rm -f && ln -s ../
if gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../libgst -I../lib-src -I../libltdl -I/sw/include/glib-2.0 -I/sw/lib/glib-2.0/include -I/sw/include/gtk-2.0 -I/sw/lib/gtk-2.0/include -I/sw/include/atk-1.0 -I/sw/include/pango-1.0 -I/usr/X11R6/include -I/sw/include/freetype2 -I/sw/include -I/sw/include/glib-2.0 -I/sw/lib/glib-2.0/include -I/sw/include/pango-1.0 -I/sw/include/glib-2.0 -I/sw/lib/glib-2.0/include -I/sw/include/atk-1.0 -I/sw/include/glib-2.0 -I/sw/lib/glib-2.0/include -g -O2 -Wall -fstrict-aliasing -fno-gcse -Wno-strict-aliasing -Wno-switch -Wno-format -Wno-parentheses -Wpointer-arith -MT enums.o -MD -MP -MF ".deps/enums.Tpo" -c -o enums.o enums.c; \ then mv -f ".deps/enums.Tpo" ".deps/enums.Po"; else rm -f ".deps/enums.Tpo"; exit 1; fi
enums.c: In function `main':
enums.c:50: error: `GTK_STOCK_COLOR_PICKER' undeclared (first use in this function)
enums.c:50: error: (Each undeclared identifier is reported only once
enums.c:50: error: for each function it appears in.)
make[3]: *** [enums.o] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

If I comment out the line containing 'GTK_STOCK_COLOR_PICKER' then the subsequent make generates another awk error (different from the one above, but apparently in the idea) but another make succeeds.

Not sure if the changes I made make a difference to anything. The resulting system passes all tests in
'make check'.  But loading blox generates the following.

% gst -qK browser/
Loading package BloxTK
"Scavenging... 92% reclaimed, done"
Object: DLD error: requested module blox-tk was not found
SystemExceptions.CInterfaceError class(Exception class)>>#signal:
DLD class>>#addModule:
optimized [] in PackageLoader class>>#primFileInPackage:
PackageLoader class>>#primFileInPackage:
optimized [] in PackageLoader class>>#fileInPackages:
PackageLoader class>>#fileInPackages:
PackageLoader class>>#fileInPackage:
/usr/local/share/smalltalk/browser/ invalid scope resolution

The copy f blox-tk is in the same directory where the browser/
is located.  I did the standard install.

Sorry this is so long, but I thought I might as well include as much data in one shot as possible. Sorry also if there is a pilot error or two in this --- I feel comfortable playing around with things on
a linux system, but in Mac OSX I'm a bit nervous...

Thanks for the good work and any help.


On 4 Nov 2004, at 10:29, Bonzini Paolo wrote:

But now I get a new error.  It looks like there is a problem in the
inclusion of "poll.h".  I played
around with this but was unable to resolve the problem. I continued to
get the make output listed below.

Remove lib-src/poll.h and it should work. I have now got a PowerBook from my employer and am testing it. So far it can build the image and even write the documentation, but it fails when building the testsuite image.


help-smalltalk mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]