help-smalltalk
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Help-smalltalk] failed compile


From: Mathieu Suen
Subject: Re: [Help-smalltalk] failed compile
Date: Wed, 29 Dec 2010 08:24:54 +0100

Did you install the dev package?
libgtk2.0-dev
libcairo2-dev
libglib2.0-dev
...

        Mth




On Dec 29, 2010, at 6:51 AM, Albert Wagner wrote:

> Paolo and Thomas:  the failed compile was apparently an ugly artifact caused 
> by not cleaning the source dir between compiles.  I can now compile.
> 
> However, as the excerpts below show, several components cannot be found and 
> hence, the compile is severely crippled. gst-Blox, gst-Browser, visualGST, 
> etc,  I have actually installed all of the supposedly missing components.  
> Perhaps you could give me more explicit names, e.g. for Cairo, I installed 
> libcairo2 "The Cairo 2D vector graphics library", but that is either the 
> wrong module, or for some reason it cannot be found.
> 
> Any ideas why the modules below can not be found?  It's been years since I 
> compiled regularly and I have forgotten much.  Could it be related to the 
> fact that I am on a 64 bit machine?
> :
> checking for lt_dlopen in -lltdl... no
> configure: WARNING: using included copy of libltdl
> configure: WARNING: this is deprecated and will go away
> configure: WARNING: it is suggested to install libltdl
> checking for LIBFFI... no
> checking for ffi_prep_cif in -llibffi... no
> configure: WARNING: using included copy of libffi
> configure: WARNING: this is deprecated and will go away
> configure: WARNING: it is suggested to install libffi
> checking for sigsegv_install_handler in -lsigsegv... no
> configure: WARNING: using included copy of libsigsegv
> configure: WARNING: this is deprecated and will go away
> configure: WARNING: it is suggested to install libsigsegv
> :
> checking how to link with GMP... not found
> checking how to link with readline... not found
> :
> checking for Tcl 8.x... no
> checking for Tk 8.x... no
> :
> checking for sqlite3.h... no
> :
> checking for CAIRO... no
> :
> checking for GLIB - version >= 2.0.0... no
> *** Could not run GLIB test program, checking why...
> *** The test program failed to compile or link. See the file config.log for 
> the
> *** exact error that occured. This usually means GLIB is incorrectly 
> installed.
> 
> checking whether to install GTK... no
> checking whether to install BloxGTK... no
> checking whether to install Blox... no
> 
> 
> _______________________________________________
> help-smalltalk mailing list
> address@hidden
> http://lists.gnu.org/mailman/listinfo/help-smalltalk

__________________________________________________
Do You Yahoo!?
En finir avec le spam? Yahoo! Mail vous offre la meilleure protection possible 
contre les messages non sollicit├ęs
http://mail.yahoo.fr Yahoo! Mail



reply via email to

[Prev in Thread] Current Thread [Next in Thread]