[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: cannot commit ... sticky tags

From: Teala Spitzbarth
Subject: RE: cannot commit ... sticky tags
Date: Mon, 7 Jan 2002 18:00:10 -0800

Yes, the sticky tags just mean that the tree you were working in
was pulled (or the one you used to create) the Release_Aug21_2001 tag,
haven't been "put on every file" in any different way than
when you tagged the tree before you left.  Developers that have been
working in sandboxes pulled by cvs co 'module name' - will not be
seeing this and will be checking-in fine.

The cvs update -A will both remove the sticky tag to the
Release_Aug21_2001 tag
in your working directory, and it will merge the newest revisions from
main trunk into any files that have been modified since that tag.

If you first run a recursive cvs status command and grep for "Needs
merge" - then
these are the files you have locally modified, and also have been
modified at the 
top of the tree by other developers.  These are the files you'll have to
carefully (and backup if you are paranoid) to make sure the merge is


-----Original Message-----
From: address@hidden [mailto:address@hidden
Sent: Monday, January 07, 2002 5:25 PM
To: Schwenk, Jeanie
Cc: CVSpost (E-mail)
Subject: Re: cannot commit ... sticky tags

cvs update -A

This will remove the sticky tags holding you to a particular release.

On Mon, Jan 07, 2002 at 05:12:44PM -0800, Schwenk, Jeanie wrote:
> I'm using cvs 1.11 on hpux.
> I tagged the Aug 21 release with the tag Release_Aug21_2001.  Just a
> tag.  
> While I was out for several weeks, the vendors who happen to be on the
> side of the world put a sticky tag on every file, including those I am
> editing.  The tag for that is identical to the one I put on in August
> it is sticky.  But there do not appear to be any branches anywhere
> associated with it (guess on my part).  There have been file
> since that particular release date on my side so I'm not sure if they
> the code from Aug 21 or the most recent.  I'm confused as to what the
> 'state' of everything is.
> Today, as I go to check in several files, I did a cvs update.  No
> Then I tried to commit my changes and I got an error.  I'd fix the
> errors first", but I don't know how to except my simply removing the
> tags.  Don't think that's the correct approach.
> Here's the error, the cvs status and cvs log for one of the files in
> question.
> cvs commit -m "lot history modifications"
> cvs commit: sticky tag `Release_Aug21_2001' for file `'
is not
> a branch
> cvs [commit aborted]: correct above errors first!
> cvs status:
>       File:    Status: Locally Modified
>          Working revision:    1.12    Tue Dec 11 02:17:19 2001
>          Repository revision: 1.12    filename,v
>          Sticky Tag:          Release_Aug21_2001 (revision: 1.12)
>          Sticky Date:         (none)
>          Sticky Options:      (none)
> Here's the log:
>       Working file:
>       head: 1.12
>       branch:
>       locks: strict
>       access list:
>       symbolic names:
>                 Release_Aug21_2001: 1.12
>                 Release_Aug14_2001: 1.10
>                 SYSTEMA_FIRST_20010525:
>                 SYSTEMA: 1.1.1
>       keyword substitution: kv
>       total revisions: 13;    selected revisions: 13
>       description:
> Can anyone tell me exactly what is going on?  Is there something I'm
> missing?  What do I need to do to be able to commit files to the main
> Obviously none of the other engineers here has tried to check in a
file or
> they'd all be in my cube.  It's not going to be a pretty site if I
don't get
> this fixed before one of them notices.  
> Jeanie
> _______________________________________________
> Info-cvs mailing list
> address@hidden

Info-cvs mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]