[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Help: Linux CVS Server Access Problem

From: Danny Sauer
Subject: RE: Help: Linux CVS Server Access Problem
Date: Mon, 9 Jun 2003 06:52:20 -0500 (CDT)
User-agent: SquirrelMail/1.4.0

On windows, you may have to specify the port in some other manner.  You're
just trying to see if you can open a connection to port 2401, and the
telnet comand's an easy way to do that - especialy with a protocol that's
easily human readable, like CVS.

Either way, you'll proably get a "connection refused" message, which will
tell you that you need to find out which of the acces control methods on
the server is rejecting the connection (ipchains/iptable, tcp wrappers,


Hill, Benjamin W said:
> That gleans the same result as a: "telnet [SERVERNAME]".
> Cheers,
> Ben
> -----Original Message-----
> From: Danny Sauer [mailto:address@hidden
> Sent: 06 June 2003 17:38
> To: address@hidden
> Cc: Hill, Benjamin W
> Subject: RE: Help: Linux CVS Server Access Problem
> You might try (from the client machine that's having problems):
> telnet [SERVERNAME] 2401
> If that works (ie, it doesn't reject your connection), try typing
> /cvs/repository
> username
> password
> Hit return (yes, forcefully strike the key) after each line.  It should
> tell
> you that it hates you, and close the conenction (because the password
> isn't
> properly encrypted and you hopefully don't have any user called
> "username").
> You probably will get stopped at the telnet part, though, since you
> probably
> have something rejecting connections on the server box.  Check to see that
> xinetd isn't set up to block connections from hosts other than localhost,
> and that tcp wrappers (if used) isn't rejecting connections to the CVS
> service.  Make sure that the LISTEN entry in netstat is listening on all
> relevent addresses (probably *:cvspserver), too.
> --Danny
> Hill, Benjamin W said:
>> Hi,
>> I have been through the troubleshooter, but not found anything I
>> haven't tried.
>> When I try to connect to the server from a Windows machine using:
>> set cvsroot=:pserver:address@hidden:/cvs/repository
>> cvs login [USERNAME]
>> ..I get the line:
>> "CVS password:"
>> ...but when I enter a password I get:
>> "cvs [login aborted]: connect to [SERVERNAME]([SERVERNAME]):2401
>> failed: No connection could be made because the target machine
>> actively refused it."
>> I have checked that the cvspserver file is in /etc/xinetd.d and that
>> there is a LISTEN entry when doing a netstat.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]