[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Ignore resources which had been committed?

From: Hans Schwaebli
Subject: Re: Ignore resources which had been committed?
Date: Wed, 21 Mar 2007 04:49:50 -0700 (PDT)

I think the Linux guy once tried to update CVS and had to compile it. Afterwards nothing worked and he had to rollback.
You write: "Your best bet might be: Disregard using "-P" on update and checkout, and
put a .cvsignore file INTO xfolder/."
I use Eclipse. Eclipse cannot disregard using -P. How could it disregard? Besides that I think it is problematic that accidentally checkid in stuff cannot be excluded from CVS by a simple command, in order to be able to ignore it. Errors happen and need to be corrected in a productive and straightforward way I think. As I said, not even deleting the folder in the repository helped. You didn't say anything to this in particular.
By the way, are you a CVS developer?

Hello Hans,

* On Wed, Mar 21, 2007 at 03:22:03AM -0700 Hans Schwaebli wrote:
> Client: Concurrent Versions System (CVS) 1.11.2 (client/server)
> Server: Concurrent Versions System (CVS) 1.11.5 (client/server)

Note that both versions are rather old and full of bugs. I would highly
recommend to update to a more recent 1.11.x version. (Although, the
problems you are having are not related to this).

> Concerning the commands used: The ones which Eclipse 3.2.2 uses...
> Besides that, we have to use the CVS version which Eclipse supports.
> The people at Eclipse don't seem to agree with the latest CVS
> developments.

Well, I do not agree with the Eclipse developments, so.... ;)

> To exclude Eclipse from being the reason for this, I used a new
> workspace, but the problems remained. It is not possible for me to
> purge this information that it has been checked in once.

Well, I either misunderstood you in the first place, or you were not

> cvs add "/Test/src/test/xfolder"
> Directory \CVSREP/Test/src/test/xfolder added to the repository
> ok (took 0:00.297)
> ***
> I deleted xfolder and checked it in:

You CANNOT check in deleted folders. This is not even possible with SVN,

What you have checked in is the removed xfolder/xfile:

> ***
> cvs ci -m -l "/Test/src/test/xfolder/xfile.txt"
> Removing src/test/xfolder/xfile.txt;
> \CVSREP/Test/src/test/xfolder/xfile.txt,v <-- xfile.txt
> new revision: delete; previous revision: 1.1
> done
> ok (took 0:00.188)
> ***

If you would use "cvs up -d" afterwards, the folder would reappear.
Anyway, since Eclipse seems to use "-P" additionally, xfolder/ will be
deleted immediately.

> Then I created the xfolder again and wanted to ignore it.

Indeed, THIS is not possible. xfolder is in the repository, thus, CVS
will handle it, regardless of what you do.

> But Eclipse
> does not allow me to ignore it, but to commit it. So I created a
> .cvsignore file and added "xfolder". But Eclipse didn't ignore it.

CVS cannot ignore the directory xfolder/. .cvsignore is used for files
and directories which are not under the control of CVS. Since xfolder/
was checked in, it is under the control of CVS. You cannot change this.

Your best bet might be: Disregard using "-P" on update and checkout, and
put a .cvsignore file INTO xfolder/.


Spiro R. Trikaliotis

Don't get soaked. Take a quick peek at the forecast
with theYahoo! Search weather shortcut.
reply via email to

[Prev in Thread] Current Thread [Next in Thread]