[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Ignore resources which had been committed?

From: Spiro Trikaliotis
Subject: Re: Ignore resources which had been committed?
Date: Wed, 21 Mar 2007 13:12:55 +0100
User-agent: Mutt/1.5.9i

Hello Hans,

* On Wed, Mar 21, 2007 at 04:49:50AM -0700 Hans Schwaebli wrote:
> I think the Linux guy once tried to update CVS and had to compile it.
> Afterwards nothing worked and he had to rollback.

I don't know which distrubution (and version) of Linux you are using.
I have compiled CVS myself on Debian and Suse and never had any

Of course, if you are using CVS completely internal only, this is no
issue. Anyway, if you use it in the Internet - especially if pserver is
involved - I would really try to update. 1.11.5 has had some security

> You write: "Your best bet might be: Disregard using "-P" on update and
> checkout, and put a .cvsignore file INTO xfolder/."
> I use Eclipse. Eclipse cannot disregard using -P.How could it
> disregard?

Well, I just opened Eclipse (3.1) myself and tried the CVS plug-in:

Menu "Windows", "Preferences..."

Then go to "team", "CVS". Select the register "Files and Folders", and
unselect "Prune empty directories". This way, eclipse does not issue -P

> Besides that I think it is problematic that accidentally
> checkid in stuff cannot be excluded from CVS by a simple command, in
> order to be able to ignore it. Errors happen and need to be corrected
> in a productive and straightforward way I think.

Unfortunately, it is the way CVS works which is problematic here.

> As I said, not even deleting the folder in the repository helped. You
> didn't say anything to this in particular.

Oh, I overlooked this.

Deleting the directory on the CVS server helps. It would be best to do
it in the following order:

1. make sure the folder xfolder/ does not exist locally (in ANY sandbox)

2. delete xfolder/ from the repository (on the CVS server)

--> you are done.

If any sandbox still has an xfolder/ directory (in which a directory
xfolder/CVS/ exists), cvs will complain on that machine that it cannot
find the directory on the server. If this occurs, just delete the
directory xfolder/CVS/ (and all of its data), any you are done.

> By the way, are you a CVS developer?

No, just a user who has learned to live with its limitations.


Spiro R. Trikaliotis                               

reply via email to

[Prev in Thread] Current Thread [Next in Thread]