[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

IO error reading [...] : Is a directory

From: aundro
Subject: IO error reading [...] : Is a directory
Date: Wed, 16 Apr 2008 10:48:43 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.0.60 (gnu/linux)


[this is kind of a "I had an error but couldn't find the solution on the 
internet so I digged, found the error, and am now reporting it in order
to -who knows- maybe help others" message]

On 16 Apr 2007,

"Cranreuch" started the following thread:


On Apr 16, 3:49 pm, "cranreuch" <cranre...@xxxxxxxxx> wrote:
> > when I try to move [from INBOX.2007 to INBOX] I get the following error:
> > IO error reading /home/cranreuch/News/agent/nnimap/localhost/INBOX/
> > 2007: Is a directory
> But in fact I've just noticed that despite the error, the move partly
> succeeds. I say partly because what I actually get is a copy, not a
> move. A copy of the article from INBOX.2007 appears in INBOX, but the
> original stays where it is.
> c.

Just to be clear - this problem is not at all solved. I cannot move
nnimap mail from a subfolder to a containing folder without an "IO
error reading ..." error.

Any thoughts appreciated.


I had a very similar problem, using p4.el 

Description: Whenever I tried to do a p4-submit (i.e., committing
changes to the p4 server), this error would occur. 

Since I didn't find relevant enough information about the problem, and
how to solve it, I had to do some debugging in the p4.el code.

The problem was:
I had set, in my _.bashrc_, the *P4CONFIG* environment variable *to
an empty string* , and the p4.el code expected the environment variable
to be set to a sensible value, or not to be set at all:


(defun p4-find-p4-config-file ()
  (let ((p4config (getenv "P4CONFIG"))
        (p4-cfg-dir (cond ((p4-buffer-file-name)
                            (file-truename (p4-buffer-file-name))))
                          (t (file-truename default-directory)))))
    (if (not p4config)   ; <-------------- that was failing, and we instead of 
returning 'nil', emacs entered the 'let' statement..
        (let ...)


Hope that might help others who would face a similar problem..


reply via email to

[Prev in Thread] Current Thread [Next in Thread]