[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gnutls-cli not there after upgrade

From: Xin Shi
Subject: Re: gnutls-cli not there after upgrade
Date: Sat, 25 Apr 2009 11:01:50 -0400
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.3 (gnu/linux)

Laura Conrad <> writes:

> I had been using a set of lines like this in my .gnus.el:
>    (setq smtpmail-starttls-credentials '(("" 587 nil nil))
>         smtpmail-smtp-server ""
>          smtpmail-default-smtp-server ""
>          send-mail-function 'smtpmail-send-it
>          message-send-mail-function 'smtpmail-send-it
>           smtpmail-smtp-service 587
>            smtpmail-auth-credentials '((""
>                                  587
>                                  "*redacted*"
>                                  "*redacted*")))
> to send mail from gnus via the comcast mail server.
> One morning some months ago I woke up and was getting smtp error
> messages when I tried to send mail, so I googled the error messages and
> ended up adding the following to my .gnus.el, before the
> smtpmail-starttls-credentials lines above, based on some post in this
> group:
>   (setq starttls-use-gnutls t
>          starttls-gnutls-program "gnutls-cli"
>          starttls-extra-arguments nil)
> Yesterday, I upgraded from Ubuntu 8.10 to 9.04, and now when I send
> mail, I get a message:
>       No STARTTLS program was available (tried 'gnutls-cli')
> The mail does seem to get sent, at least when I send a test message to
> myself.  But the gnutls-cli program doesn't seem to be there any more.
> Is the gnutls program necessary? If so what should the
> starttls-gnutls-program be set to?  If it's gnutls-cli, where am I
> supposed to get that from?

> Thanks,

Hi Laura:

You can try "gnutls-bin" package. 

See this page:


reply via email to

[Prev in Thread] Current Thread [Next in Thread]