[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Jailkit-users] How to jail Opera or Firefox...?

From: Hubert Havel
Subject: Re: [Jailkit-users] How to jail Opera or Firefox...?
Date: Mon, 28 Aug 2006 20:37:29 +0000

Hi Olivier,

I finally got Kinternet working inside chroot. KInternet get its internet info from the smpppd socket in /var/run/smpppd/control. I simply did a "mount /var/run/smpppd /chroot/var/run/smpppd -o bind". Kinternet can now detect WiFi internet connections using this smpppd socket. I invoke Kinternet
by invoking  the command    "ssh -X address@hidden /opt/kde3/bin/kinternet"

I also have Opera running inside chroot. I can invoke it by a similar ssh command:
           "ssh -X address@hidden /usr/bin/opera"

The problem is that the Opera running inside chroot cannot connect to the internet, or perhaps it cannot detect the kinternet running inside chroot? However, when I run Opera outside chroot Opera can connect to the internet (through the kinternet running inside the chroot!) and I can surf normally. What is happening? When I run kinternet inside chroot why is it that Opera running outside the chroot can connect to the internet and if I run Opera inside the chroot
it cannot?!  I am running SuSE 10.1

   Once again, thank you for your help!!


From: Olivier Sessink <address@hidden>
Reply-To: address@hidden
To: address@hidden
Subject: Re: [Jailkit-users] How to jail Opera or Firefox...?
Date: Mon, 21 Aug 2006 08:08:28 +0200

Hubert Havel wrote:
> I finally got Opera to work in jail. Thanks, Oliver, for your
> assistance. However, I was trying to connect it to WIFI internet using
> Kinternet. (in SuSE 10.1) There when I tried to invoke
> Kinternet inside the jail. By invoking the following command:
>    ssh -X address@hidden  /opt/kde3/bin/kinternet
> I got the following message:
>    &#8220;There is an error setting inter-process communication for KDE.
> The message return by the
>    system was:  Could not read network connect list.
> /home/janeDCOPserver_hostname_localhost_10     Please check that
> DCOPserver is running.&#8221;
> As it turned out, the .DCOPserver_hostname_localhost_10 file does not
>    exist in the (jailed jane home directory: (/home/jane).

where _does_ it exist? if this is a socket in /tmp/ you might need to do
a bind mount (mount /tmp /home/jail/tmp -o bind) to make it available in
the jail.


Jailkit-users mailing list

Check the weather nationwide with MSN Search: Try it now! http://search.msn.com/results.aspx?q=weather&FORM=WLMTAG

reply via email to

[Prev in Thread] Current Thread [Next in Thread]