[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [libmicrohttpd] Select timeout being set to 0

From: Jon Nalley
Subject: Re: [libmicrohttpd] Select timeout being set to 0
Date: Fri, 28 Oct 2011 14:54:55 -0500

Hi Christian,

I am using 0.9.15.  I also tried to reproduce the issue on a "standard" x86 Debian Linux box and was unable to do so.  I am wondering if my issue may be related to uClibc on the PowerPC 405.


Jon Nalley

On Fri, Oct 28, 2011 at 11:14 AM, Christian Grothoff <address@hidden> wrote:
Dear Jon,

I've tried (and failed) to reproduce your problem.  I've attached my modified version of 'minimal_example.c' (modified to use a thread pool).  When I connect to the server with firefox, the socket stays open (will be re-used by the browser) but MHD does NOT use any CPU after the page is served initially.

I do recall a bugs that could cause similar behavior of MHD looping in older MHD versions (prior to 4.5) and there was also a bug with looping for up to 1s before 0.9.12.  Which MHD version are you using? (We're currently at 0.9.15, another release might happen later this weekend.)

Happy hacking!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]