[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: compile error: kpsexpand not found

From: Mats Bengtsson
Subject: Re: compile error: kpsexpand not found
Date: Mon, 16 Feb 2004 11:02:15 +0100
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

kpsewhich and kpsexpand are standard programs in the teTeX distribution
and should be available in your PATH just as much as the tex and latex
commands, for example. I've got the impression that some distributions
put these commands in a separate package, for some weird reason.
Anyway, you will need the programs both during compilation of LilyPond
and in run-time.


Edward Sanford Sutton, III wrote:
When building lilypond from CVS, I run ./ --with-kpathsea-include=/usr/share/texmf/include/ --with-kpathsea-lib=/usr/ share/texmf/lib/ as one of the steps. Configure and make proceed just fine. As my normal user, my path also includes /usr/share/texmf/bin/ in it which avoids configure stating 'WARNING: Please consider installing optional programs: kpsewhich' and make failing because it cannot find kpsexpand.
  Once I run make install as root, kpsexpand isnt found (root has a path of /
usr/local/sbin:/usr/local/bin:/sbin:/usr/sbin:/bin:/usr/bin). Is adding kpsexpand to root's path the preferred way to properly resolve this build error? The end of make install's output is included below to help point out the section of the install phase (would more of the output be helpful?) I can't recall always having this issue until some of the last few CVS versions.
Thanks again,
Ed Sutton
if [ -f out/lilypond.nexi ]; then chmod a+w out/lilypond.nexi; fi
/usr/bin/python ../../scripts/ -I -I ./out -I../../input -I ../../input/tricks/ -I ../../input/regression/ -I ../../input/test/ -I ../../input/tutorial/ -I /home/mirror176/downloads/src/multimedia/
lilypond/CVS/lilypond/mf/out/  -I /home/mirror176/downloads/src/multimedia/
lilypond/CVS/lilypond/mf/out/ --output=./out --format=texi --verbose --process="lilypond-bin -I ./input/test -e '(ly:set-option (quote internal-type-checking) #t)'" --process='true' lilypond.tely
lilypond-book (GNU LilyPond) @TOPLEVEL_VERSION@
lilypond-book: error: `kpsexpand \$TEXMF' failed (127)
lilypond-book: error: The error log is as follows:
sh: line 1: kpsexpand: command not found
make[2]: *** [out/lilypond.nexi] Error 1

Lilypond-devel mailing list

        Mats Bengtsson
        Signal Processing
        Signals, Sensors and Systems
        Royal Institute of Technology
        SE-100 44  STOCKHOLM
        Phone: (+46) 8 790 8463                         
        Fax:   (+46) 8 790 7260
        Email: address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]