[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Sat, 30 Jun 2007 14:19:19 -0300
Thunderbird 188.8.131.52 (X11/20070615)
Werner LEMBERG escreveu:
>> There's a single event class, StreamEvent, which uses uppercase
>> letters in its name. Wouldn't be stream-event a better name, similar
>> to all others?
> To be more precise, we have for example `AbsoluteDynamicEvent' for
> music expressions and `absolute_dynamic_event' as a music class, but
> `StreamEvent' is the name of both a music expression and a music
> class; the latter should be `stream_event' IMHO for clarity.
I don't understand this remark:
address@hidden lilypond]$ grep StreamEvent */*
scm/define-event-classes.scm: '((() . (StreamEvent))
scm/define-event-classes.scm: (StreamEvent .
Han-Wen Nienhuys - address@hidden - http://www.xs4all.nl/~hanwen